Load screen freeze WU6 orbx EGLC London city

Still getting CTD with orbx london city airport.
I understand Orbx has issued a fix for people that have bought from Orbx but for those of us that have purchased from market place we are still awaiting them to OK the update. Orbx can only advise to express my frustration with Asobo.
Luckly i have only bought this one item from marketplace so have learnt my lesson. Please Asobo update this product version. It has been an issue since SU5.


If it was less expensive, I’d say uninstall the Marketplace version and buy a fresh copy from Orbx.


I do think asobo have shot themselves in the foot with this one. Market for me is only a
means to update asobo products.
Airports are too expensive in my eyes. I understand they have to sell at a price so they make it worth their well. I won’t buy any unless their exceptional well made with plenty to explore. Plenty of freeware out there.

I have this one - bought direct. It’s actually quite nice. It’s my go-to any time I’m flying into London. The 5.5° glideslope is a real challenge!

Orbx EGLC is fine for me and has been since I purchased it. There is a known issue with Orbx London Landmarks (marketplace version) taking off from EGLC. Do you have that installed as well? Delete it.

No I don’t have landmarks London.
I don’t have trouble flying from default London city airport only when I have orbx one installed.
It was working fine Pre su5.
I suppose I could try redownloading scenery from
Market place although seems pointless.

Actually I apologise it doesn’t ctd, it gets stuck on the load screen and I have to ctrl alt delete and force quit to desktop.
The timer stops rotating and progress bar freezes. If I don’t quit then I’ve had it hanging there for 20min. I have various other paid add ons from orbx and others but I only have an issue with London city airport add on.
If I get remove all other add ons from community it still happens. However I have had more luck starting from say Manchester and flying down to London city and that can sometimes work but as soon as I load to run directly from London city then I get this issue.

That’s very interesting because that’s the EXACT behavour I get when Orbx London Landmarks is installed - loading up to about 70% and then crawling up to 100% but never actually finishing. Flying from Orbx EGLC with Orbx Landmarks has this issue but removing Orbx London Landmarks fixes the problem.

1 Like

Here’s some things you can try from the Orbx forums. If you are using the Steam version then you’ll obviously have to find the steam location instead. All these files will get rebuilt when starting the simulator.

  1. Delete any rolling cache.
  2. Delete the Content.xml file.
  3. Delete the simulator .dat files
  4. Do not add anything to the Community folder

Also remember to check the Content Manager and update any scenery there as well.

Redownloading may help if you have any files in the pack that are damaged. Check the manifest.json and see what your version is (or in the content manager). The current version on the Marketplace is 1.1, while it’s 1.2 for the current direct sale version. If your version is lower than 1.1, the content manager should list it in the Update Available category.

I actually bit the bullet on this and re-purchased the couple of airports I had bought through marketplace (bought before I realised what a trainwreck it was.)

Haven’t looked back since but I do kind of feel for the Xbox users. They are stuck with it and are getting shafted.


Have a read at this

Yep I used to live in thamesmead in flight path. Now live in NZ but holds good memories for me.
Yep unusual steep glide slope.

Thanks for this, it was an interesting read. I do have a couple of Drzewiecki Design products and they load fine all be it I bought them from Justflight. They suggest they expected a fix in SU6.
It obviously hasnt been fixed yet. Sounds like Im not the only one with this issue and some other 3rd party airport add ons from Market place have same issue. There is a suggestion that disabling bing data may help. I have deleted contents.xml file but this hasnt helped. It seems asobo have been made aware issues are occuring but on most part they are having issues replicating. I had no issues before SU5.

I have 1.1 and thats why im keen for Asobo to update this product on market place.
My hope was that 1.2 would cure my issue. Thanks for comment

I have done most of these things. I havent deleted sceneryindex. I will give it a go later tonight.

Hi all, so I redownloaded London city from market place last night and ran more test.
Still freezes.
I deleted scenery indexes. No change.
I turned off bing maps and photogrametry
I then manged to load into london city. However this proved a fluke as I tried with it off after a few other restarts and it froze again.
When it freezes msfs memory gets stuck or slows to a crawl.
I now feel I’ve tried all possible solutions that you guys have given and still 95 percent freezes with orbx airport. My options at moment are to wait for market to update this version to 1.2 or attempt haha to get my money back from asobo.
As I cannot use this airport and all seem to be playing the blame game.

Be sure to tell them everything you’ve done to troubleshoot, along with the fact that Orbx has said that the 1.2.0 files have been waiting for approval. Then ask them to either refund your money because their update rendered 1.1.0 inoperable or move forward with approving 1.2.0 so that you can finally update.


Well I tried and this is their response.

‘It’s been longer than our refund policy allows for digital game products. Thanks for understanding’.

Maybe a little bit of help would be nice from them . At the moment I feel just like a number.

You could try opening a Zendesk ticket and asking that they expedite the 1.2.0 approval, but recent experience with that avenue has been… umm… less than encouraging.