Logbook not updating after patch

I thought you said you didn’t get logged. which I assume the logbook at the end of the flight didn’t appear. to me whenever the logbook appears, my flight is logged. But if I sit there on the parking spot after I cutoff my engines and the logbook doesn’t appear to end the flight. My flight isn’t logged.

So that’s just a trick I do when my logbook doesn’t appear, (which signifies my flight isn’t logged) and I do the trick to get my flights logged.

I suppose it’s forcing the game to log the flight the same way it behaves with your other flight. Logging the hours without having the logbook appears.

ok thank you. until this gets fixed i will try this as a workaround and take care, the logbook appears.

That would be useful in those occasions where the game is stuck in any other state than the “taxi to destination”, then “Shutdown main engine” states. I’ve seen that on occasion, and as a workaround for that I have either requested takeoff, and performed a quick circuit, or even flown to a different airport.

If I get this again, I will give this technique a go instead. Thanks.

The fix has now got a date of 2021 in the latest dev update. A more specific date should be forthcoming once they release the new dev schedule soon (current one ends this month).

2 Likes

I’ve seen this. I am not exactly happy about it, but at least it’s on their track. Superficially, this might seem easy, but according to what I gathered here, it might well be they have to rewrite the complete logbook logic.

2 Likes

I think part of the just 2021 date is that they haven’t set out their updates pattern yet and then there’s the likely fixing any issues with the next World update and Xmas. (Oh, and VR addition)

I suggest anyone that having the log problem post here also post the airport you are having problem with it and aircraft used, some of us maybe can try it out.
I can log all my flight but only CTD can mark Vicinity on my logbook :disappointed:

For me… I usually fly in the 747, I’ve been making notes of the airport I went to ingame to see which flights I can get the logbook to fully work

Hopefully this should help people in the forums :slight_smile:

Airports where I been so far and able to park 747 when requested by the ATC with flight fully logged are…
heathrow, manchester egcc, gatwick, mumbai, dubai, jfk, paris int, lax, kord, philly, ksfo, frankfurt, eham, toronto int cyyz

Airports I been so far in the 747, couldn’t tune into ground freq after landing but parked at the default location given to me… even with engine and battery off… showed flight logged as vicinity are…
birmingham egbb, orlando int, anchorige ted stevens, east midlands airport, san diego, lfmn nice cote d’azur airport, glasgow, munich eddm
^ no issue parking in the real world at them airports though :stuck_out_tongue:

I don’t have any issues with the smaller aircrafts as they get fully logged no problem

1 Like

Can you try those airports that you have problem with A320neo to see if you can get ground to assign a parking ramp?
I only fly GA for now with my under power video card(1050), any jetliner I got only 8-11 FPS not flyable.

My last logged flight was 13 October, nothing since. I use dev mode a little.
Mostly cessnas in France but nothing.

I’m only landing at birmingham egbb to save time since the result will be the same of the airports I mentioned, may I ask which airport you want to land with the a320? I’ll see if I can trigger the flight ending

here’s what I did to trigger the flight log in the a320
loaded from approach to save time, landed, got off the runway, tower asked me to switch to ground, I stopped, contacted ground, ground gave me a gate number to park at, I went there, parked in the box, turned engine off ctrl+shift+e… lights can be turned off too if you want to… I didn’t in the video, checked the rpm going down (or hear the engines whining down), tuned off master battery 1 and 2, flight log screen showed up for confirmation, exit to menu then profile then my log

^ all mentioned here video below, ignore my landing lol

2 Likes

It happens rarely… Most times, I’m lucky have everything works like you did.
Sometimes, when I switch to ground ATC after landing, it doesn’t show the choice of taxi to parking or gate. It’s only showing taxi to depart. That’s when the problem happened.

Without proper gate assignment from the ATC, the sim doesn’t register that you’ve completed your flight. so when you park at the gate or wherever the taxi ribbon takes you, cutting off the engine won’t end the flight.

So I did my workaround that I posted earlier, and I got it logged in my logbook.

PS… that’s a very hard landing, Because your nose is too high on final approach, so the aircraft is already dropping and couldn’t flare to reduce the rate of descent. When you’re on the glideslope and full flaps configuration, you should be approaching at almost level nose pitch. about 0-3 degrees positive pitch. So there’s enough kinetic energy forward that when you flare, it would slow your descent rate better. Don’t aim for the AOA on the HUD here, that’s used for GA aircraft and shouldn’t be used as a reference for A320.

Your throttle is in the wrong position as well. It shouldn’t be on A/THR 51%. It should be sitting at 85% CLB mode. And you retard the throttle too early. You should leave it at CL 85% until 50 feet callout, and retard the throttle straight to idle at 30 feet, as you flare at the same time.

2 Likes

I find that turning on taxi waypoint assistance is the only way to complete the flight sometimes. On a massive parking lot with dozens of aircraft and hundreds of open spots, the simulator has picked exactly one spot that it wants you to park at with no markings, no flag guy, no indication at all the magic square where the game wants you to be when you shut down the engine and avionics.

Thank you for trying it out. It really kind proof my suspicion that something to do with the MSFS scenery library airport data, you have problem with 747-8 that wingspan is 225’, and A320neo is about 117’.
Now look the EGBB, biggest parting /gate is ramp/parking # 7 witch is 118’ , that is the reason I ask you to fly a neo to see if you’ll logged (and in the video, ground did send you to #7!!)


I found out this a while ago when LNM be able to load up the MSFS library, study it and did the many test. And I did try to tell ppl what type the airplane related to the airport matters, anyone that land a controlled air port found out there isn’t a parking option means there isn’t a suitable parking space (in game, NOT rl) for your aircraft, many of you fly like TBM930, King 350, C208B, CJ4, Longitude (Mid GA) will have more un-parkable airports then those who fly small GA, same to those airline pilots, A320 can part/gate more then 787 and 747.
Still testing, there still some airports the parking spot that is smaller then the wingspan (my favorite C208B, 52’) and I’ll be able to park and end flight.
In the end I believe logbook logic works, just the data base of the airports might need to (fix)mach the real world.
Here is the map of EGLL and look the size of that parking/gate space for your 747-8 !

1 Like

not a problem :slight_smile:

I did some testing… and as you mentioned I would go with ingame parking allocation depending on wingspan size, not comparing to real life. Ingame on the airport selection… birmingham egbb shows only small and medium gates… obviously 747 is a heavy… in real life there’s an actual gate designed for a380… I can always place a parking spot with the sdk for the 747 on flight sim… I need to learn how. egbb is my local airport.

747 wise, landing at airports with gate heavy listed will park without issues with logbook working, I landed at philly, after landing ground freq gave me an option to park at gate or ramp GA large parking.
I checked orlando int airport in game, it mentions GA large ramp… I’m not sure about the large gates since the parking list was long… I decided to load the game from approach… I landed… although the airport mentions large ramp parking… ground freq was blank :frowning: , I already reported to zendesk about large ramp spot not detected after landing… maybe the parking detection doesn’t work at all airports

thanks for the map of heathrow, although I frequently visit there in game every few days :slight_smile: , I start at ramp 3 (across 254 on map, east) when I load the game… and whatever the ground says after landing

I have been noticing this bug as well, just completed a long haul flight from EDDF-KEWR and it didn’t get logged, along with a lot of flights I have done in the past. Glad to have found this topic! Would really like for this bug to be fixed sometime soon.

In the meantime, if anyone would like to check it out, SimToolKitPro offers a logbook so that you can log your current flights for now :slight_smile:

I think that everybody who is experimenting the logbook bug should give this trick a try. I have been using it for a while and it is better than nothing.

Also there is another trick written by @Neo4316 in other thread that I have just tried and worked for me. If you let me @Neo4316, I am copying your words: If you’re using the taxi ribbon, make sure you park in the green box without making it disappear. So stop slightly early, and cutoff the engines. If the green box disappear and the jetway automatically connects, you’re too late. No log when that happens.

I have just done this and the logbook window popped up. I stopped as soon as the little guy at the gate with the two red bars in each hand giving the signals to apprach to the gate raised his hands and crossed the red bars. The green box was still there but when I cutoff the engines the window popped up.

Yeah… I’m a master at workarounds… :grin:

Some questions for Asobo:

  • What triggers the logbook entry?
  • Is it tied to communication with ATC?

Having a partnership with VATSIM and people flying with IVAO who will not use the default ATC, it is not convenient to tie logging to ATC.

I guess most people simply want an entry for takeoff and one for landing and leaving the runway, simple as that. That way you enroute time is logged. Everything taking parking into account is too error prone.

Currently the flight time is way of or not logged at all.

Sometimes my flights are logged but often ended in the vicinity on the half way. I have never seen a popup at the end of the flight. Shutting done the engine makes logging more unlikely. Hitting ESC during flight seems to interrupt flight tracking, too.

5 Likes

Still an issue as it seems Actually up until now I had never realized that logbook is not logging flights as I had logged over 106 hours. However ever since I began using Pilot2ATC (effectively disregarding the ingame ATC), I think none of my flights has been booked correctly.

There is an entry in the loogbook and the departure airport is correct. However it shows as zero minutes and the arrival airport (which should be hundreds of miles away) is the same as the departure one. I suspect an issue may be that since I’m not talking to ingame ATC, my IFR flight plan is cancelled and the game simply closes the flight and doesn’t log anything. In reality Pilot2ATC takes over all comms.

Next time I’ll try to at leas initiate some comms with ingame ATC if only to get IFR clearance, although I suspect this’ll get cancelled later if I don’t reply to their calls.

Pretty disappointing anyway. I must have lost at least 10-20 hours of flying or more.

edit: just taking a closer read at the thread and it seems there are many people experiencing the exact same symptoms. I’ll try the restart method and see if it makes any difference.