Logitech autopilot panel red screen

Hey i just bought the panel for msfs Autopilot and it is now working only red light and when iam restarting the PC it just showed up alt and things like that but when win 10 is loaded it is only red screen

They can be a little finicky. I’ve had that happen but usually USB weirdness.

  1. Are you connected directly to a USB 2.0 (black or white but not blue/red) port on your PC?
  2. Did you load the plug-in / driver? Make sure you use the right one–they have all kinds of old versions up there.
  3. Did you try the test app that you can download from Logitech?


okey so iam put it in black it says it is 3.2 … i download it from the original site the latest i already tryed the older one and none of them works and test app doing totaly nothing only showes me the panel but if i press something it is without the reaction

Topic moved into #self-service:peripherals for further discussion.

Funny thing is … that i cant see that device in device manager it looks like it is not connected

Hello, i strongly advise you not to use Logitech drivers but to use Spad.next with Saitek / Logitech products, it is not very expensive and that will solve a lot of small problems.

As said by @mjchernis it is absolutely necessary to connect to the USB 2 not USB 3.

If it is plugged into a USB HUB, make sure that it is properly powered.

My whole home cockpit is configured with this software.

1 Like

1 Turn off fast startup.

How to

Go to > sytsem settings > system > power & sleep > additional power settings

Click > choose what the power buttons do

Change settings that are currently unavailable

Unselect > turn on fast startup.

Turn off PC.

2 Also disable hibernate

How to

In windows search bar type CMD
Right click on CMD and select run as administrator
Copy the command below and paste into CMD (right click to paste into CMD)

powercfg.exe /hibernate off


press enter

Restart PC.

3 Go to windows settings > system > power & sleep > additional power settings
Select ultimate performance

Reboot the system.

Go to > device manager > universal serial bus controllers
Right click on USB Root Hub

and select properties

Go to power management tab and uncheck “allow the computer …”

Click Ok and reboot the system.

Also check human interface devices

1 Like

Done every thing and still nothing … AS you can see restarting pc and the panel showing this

1 Like

I use this panel using the logitech driver and plugged directly into the computer usb 2.0 port.
During windows startup, the panel will blink on and off displaying, I think, ALT/VS briefly. Once windows has finished booting, the panel goes blank until I start up either xPlane or MSFS at which time it will display whatever is selected by the rotary switch and works as expected after that.

While iam in the bios the panel is working then boot up and nothing

Agree on Spad.Next–much better–but if the panel is fine while in the BIOS you probably have some kind of driver issue. I’d remove all things Logitech/Saitek and start again.

Okey so i tested out on GF pc same usb 3.0 and its working … it is showing device in connected devices … iam totaly exhausted where is the problem…

Here’s a vid that might shed some light on the problem: Logitech Saitek Pro Flight Multi Panel screen not turning on fix! - YouTube

May or may not be relevant.

1 Like

A few minutes ago I bought Logitech G Saitek Pro Flight Multi Panel for a cheap price (80 euro).
Let’s see what happens tomorrow :smiley:

Thanks for the reminder @Striker178 :slight_smile:

Okey so i know where the problem is but dunno how to fix it. When i plug it to the PC the panel is no detected by Windows… when i try it on gf PC automaticly detected and started downloding win 10 driver … so how to fix the detection problem?

USB Legacy enabled in BIOS settings?

What about XHCI and EHCI?

What motherboard do you have?

I had a similar problem getting the multipanel to display properly. What worked for me was to run a program called capmes.exe. If you google “APM fix for Saitek panels” you should find suggestions and a link to where this can be downloaded.

Okey boys so this is the thing which worked for me

Everybody thanks for the help closing this thread as done! Thanks again

1 Like

Yo! i have Exactly the same issue. what did you do?