LOGITECH Extreme 3D Pro - Rudder control not working correctly

I have a Logitech Extreme 3D Pro joystick - nearly new condition so before you ask , yes it works ok but not so in FS2020.

I have assigned RZ +/- to the rudder as it is by default. The problem in the sim is that when you want to progressively use the rudder in the air or on the ground to steer you only get 100% like a switch and not progressive on the potentiometer as it should. makes flying the plane with rudder input completely useless, you either get 100% rudder or nothing.

is this a LOGITECH issue with the controller or the game, pretty sure the rudder twist shouldnt be on/off switching.

i have tried logging a support request directly with Logitech too.

i fly without the mapping to he joystick and use the numpad to control rudder, not ideal but i wont let this ruin my awesome experience in the game.

You need to unbind the +/- commands from the rudder and use the Rudder Axis command. Search the threads for “Axis”. All linear (proportional) controls need to be bound to Axis commands. Make sure to clear any current control bindings. Unfortunately some of ther Default bindings are incorrect on some controls. Rick


hi, so you mean to unbind the default keyboard setting thats already pre programmed to the numpad 0 & ENTER keys. then reassign to the joystick RZ Axis?

will give that a go… also realised my daughters account was logged in so this is me replying to my post !!! lol

1 Like

:slight_smile: You’re not the first to get tripped up by an incorrect login! MSFS will automatically save your configuration to your default account. The keyboard bindings won’t interfere. Each controller operates more or less independently. Just make sure the flight control inputs on your joystick aren’t bound to the “binary” inputs by default.

1 Like

i have tried the unbind of rudder to keyboard, assigned rudder to the RZ Axis on the 3D Pro but still doing the same, only switching left/right when twisted, still not being progressive.

i also went back to the logitech device manager to calibrate controller again and in the calibration page it is showing as a switch when twisted and not progressive like the throttle or the X/Y axis…

i am now thinking this could be a driver issue with the controller and not FS2020…

will try to uninstall the driver etc…

1 Like

I also had the Logitech Joystick and tried to get it to work. It just doesn’t work well with MFS. Rudder is a joke. I got the Thrustmaster T.16000 and it has worked perfectly with a little sensitivity adjustment. Has made the sim 1000x more enjoyable.


1 Like

yup thanks for that… im pretty sure i know how to map the controls…

i think the issue lies with the driver, just trying my way through delete the logitech game controller software and joystick driver… if nothing else works i guess im buying a warthog HOTAS joystick or a yoke and rudder setup…

ALL FIXED - as i suspected, it was the actual LOGITECH profile software and driver that was not working. uninstalled both software and driver, went back to the basic plug and play and calibrated the joystick in devices menu and hey presto the twist is now working and in FS2020 its perfect… no more button rudder for me…

thanks for the support. happy flying


I use a logitech ex 3dpro and report no issues …I highly recommend adjusting and changing the sensitivity settings for more control of the rudder.

Thanks for the heads up on this as well. I dusted off my E3D pro and it’s worked well enough, but i’m also just running off the default Win10 plug n play driver and haven’t loaded any of the Logitech software yet. I may just avoid that for now!

I have the same joystick. Did some changes to the sensitivity and all is well. Only problem I seem to notice is that when I land , the rudder seems like it has a mind of its own and jumps all over making it hard to steer. Will work on that some more.

1 Like

Do you have Rudder assist turned on?

Thanks for the tip. Wasn’t aware of this option. Will give it a try. So much to learn!

Same thing worked for me, as well. Uninstalled Logitech Game software and now I can steer on the ground.

I have Logitech extremo 3D pro, it is new. It was working just fine without any type of issues, BUT, after this last update 5 I have been having issues with the rudder I can not make any left turns in the ground and The rudder does not work while flying. I guess I will have to wait till next MSFS update hopping they fix it. Does not matter if I try to set up it again or reinstalling the driver or recalibrating everything, still does not fix the problem.

I have the E3DPro stick and the Logitech Gaming software is installed, and the rudder is twitchy and unusable when bound to the twist-axis on the stick.

Logitech’s stick appears to be partially at fault but this issue only happens in MS FS, and not in XPlane, so it’s not purely the fault of the joystick or a driver.

It’s a bad interaction between MSFS and this particular stick, which has the Microsoft HID Compliant Game Controller driver version 10.0.220000.1. No logitech drivers are on the system even though Logitechs Gaming Software is installed the gaming software has no configuration options for the Logitech joysticks, and is installed only to control the G600 gaming mouse.

Clicking Start → Run → joy.cpl, and recalibrating the axis has no effect.

Has anyone been able to fix this PERMANANETLY !?!?!?!?!

I can fight with it for a hour or two and get it working but the next MSFS update (or other random things) will cause it to revert to a hard right turn only. Taxiing is near impossible and coordinated flight is a huge chore. Typically it will be fixed for a month or so … then back through the deleting and downloading of drivers, resetting everything, etc … I have searched all of the suggestions here and NONE of them fix the problem.

Help before I jump from a tall building !!!