Logitech Flight controls CTD or as soon as I plug them in

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
NO

Are you using Developer Mode or made changes in it?
NO

Brief description of the issue:
FS2020 crashes on start or as soon as I plug in the Logitech Flight controls (Yoke, Throttle and Pedals)

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
see below

PC specs for those who want to assist (if not entered in your profile)
i9, gtx1660, 32Gig ram 1 tb M2

Did you submit this to Zendesk? If so, what is your ticket #?
Not Yet, but will shortly if no one as any ideas.

Okay here is the summary

Controllers have worked fine in the past, other than the not centered issue on occasion, and that is what as triggered this issue. Following the regedit to remove the calibration and reset has worked since last year, however the most recent reset now has FS 2020 crashing all the time.

When I start FS2020 with the Flight controls plugged in, it will crash near the end of the loading process. If the controls are not plugged in, it will load, but will crash shortly after I plug them in (as suggested by another post to reset controllers).

Reinstalling FS2020 does not fix the issue (it did in the past, but not now). I had to restore a backup last month at which point it worked, until I had to do the regedit reset again, I am not doing the backup restore again as this is not the solution.

Have looked for updated drivers controller drivers, and even removed them and tried the windows built in drivers.

I suspect some that I need to reset controller settings, on the computer, or in FS2020

Any suggestions?

App log
Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Exception code: 0xc0000005
Fault offset: 0x0000000000e90883
Faulting process id: 0x47a0
Faulting application start time: 0x01d7280505465c1c
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: d05070de-20bf-46ac-97a3-2d510f7160c1
Faulting package full name: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

I get the exact same error code, in the same manner (CTD during startup, or CTD when plugging the peripheral in). But it occurs only when I try to use a SECOND logitech throttle quadrant. The game crashes during loading (about when progress bar has passed 50%, and the ‘iconic flight’ double image shows) with an immediate CTD. The problem also occurs if I unplug one throttle and try to connect it when the game is running! Both quadrants are correctly recognized by Windows. I’ve no problem using them in FSX, for example. Swapping the quadrants doesn’t fix the problems. The 2018 Logitech drivers do not affect the problem (it occurs with or without it) I tried unplugging the other joystick/controllers, I tried deleting the profiles I configured for the one throttle that works, the problem occurs invariably… I’ve opened a Zendesk request, I suggest you do the same. Ah, I’ve tried also using USB 2.0 only ports, since I’ve read that Logitech hardware sometimes has trouble with 3.0 ports, with no result.

After another hour of searching and trying, I eventually solved the problem following exactly the steps described here: Corrupted cloud save - #5 by tamalien - apparently is a corrupted cloud files issue. Probably it’s something related to last friday night network/server problems.

In the end, that too is what fixed it for me. There needs to be a better way.