Logitech or Saitek throttle quadrant half scale for Throttle and mixture

I have two 3 lever quadrants, 1 Saitek and 1 Logitech G Pro, both look identical and work identically and correctly through full scale deflection on both windows calibration display and P3D 5.2.

However when I use them for the B58 Baron in MSFS, the throttles and the mixture movement only commences after the levers mixture and throttles have been moved above half scale physical deflection. Therefore only half of the movement of the throttle and mixture is being used even though when I calibrate them through the control setup I see the full range of motion.

I have searched for answers to this without success. I would appreciate any help.

I have the same problem with my Saitek TPM

1 Like

I have the same problem with the Saitek quadrant, but only the left and middle. Time-by-time I suvócceed solving it, but I don’t know how. I used to play with the Windows USB Game Controllers setup, plug in - plug out etc. Presently again it is not working.

It’s not only in the Baron, it looks to be in the Bonanza too. It also looks to be a coding design fault because even the calibration page shows up fine for all six of my axes (3 x2) when programmed.

I suspect many others have the problem, they just haven’t noticed it.

When you say only the left and middle, to be clear, are you currently saying that your mixture and throttle are the problem?

That is also the same problem that I have, across two quadrants on a twin engined aircraft.

I have solved this issue now myself. You need to clear the mapping for mixture that shows (0-100%) and change it to the axis that just shows mixture 1 or 2 respectively. The same with the thrust levers. I don’t know why there’s a difference but it worked for me. All three axes on both engines now working well.