Logitech X56 Throttle

I had been using a thrustmaster hotas one for a while and it worked fine, however I was able to procure a X56 set up as an upgrade. I mapped everything to my liking and all runs fine, except for one thing; when I bring my throttle down to zero, I kill the engine. Is there a way to calibrate the throttle, so that when I bring it down as low as it can go, it doesn’t register as zero input?

Hopefully I’m making sense.

I use X56 and have not had this problem (at least not yet) - on what aircraft are you seeing this behavior?

I tried it with the tbm930 and icon and. Same result with both.

did you remove the binds for prop settings and mixture settings?

by default they are mapped incorrectly

I had the exact same issue, till i removed the prop/mix binds

@Jimborama8487 are you having any problems with the 748i and throttles randomly ignoring input and just locking up and freezing in last position on your X56?

I also have a X56. Is your ‘Joystick L-axis Y’ (x56 throttle) beside to the ‘Throttle axis’ also by chance linked to the ‘Propeller axis’?

Prop and mixture binds we set. Working fine now. Thanks a lot guys. Probably would have taken me a while to figure this out.

Yeah, by default the other half of the throttle maps to mixture. I had the same issue initially for mine. I set a separate config for planes that require mixture / prop RPM and those that don’t.

Yep same issue for me when I first started, it’s not very intuitive! I now have mixture and prop speed mapped to the dials on the base… works a treat :slight_smile:

In my experience, it’s best to remove them completely for aircraft that don’t use them just by saving a second no mix/prop profile for your throttle and switch profiles when you switch planes.

I also use the knobs for those settings, but if you so much as breathe on one of those while flying the TBM or CJ4, it WILL shut down your engines in flight.

1 Like

you can bind the L and R Throttles for multi engine aircraft easily also.

for twin engine aircraft L Throttle is mapped to Engine 1, R Throttle engine 2.

for the 747 and anything more than 2 engines, L Throttle is Engines 1-2 R Throttle is Engines 3-4.

works pretty awesome.

if and when i get my hands on tri-engine aircraft, thats going to be a bit wonky lol

how did you that? I can’t do…

Rebind your controls in the controller menu. Unassign the mixture from the secondary throttle lever and then bind it to one of the knobs of your choice.

it works about the mixture, then engine isnt killed anymore. About throttle it doesnt work as when i pull back it all is not able to keep the idle position.

Post a screenshot of your throttle settings. We might be able to help you out :slight_smile:

Problem solved following Logitech calibration reset from regedit. Thanks a lot!

Hi - can anyone tell me how I can map number keys to a button on the x56? For example, if I’m using AI ATC, and I want to map option 1 (that can be called by pressing number 1 on keyboard), is there a way to map this to either the throttle or stick so I don’t need to use the keyboard?


You can easily map any ATC command to the throttle. Since I got a Stream Deck a few weeks back, most of the buttons and switches on my x56 throttle are unused now. I use the main switches (SW 1-6 and TGL 1 & 2) for ATC commands 1-0.

In the controller menu, look for ATC commands and you can map them to whatever you want.

Great thanks

Hi again…

I’m trying to use the mode switch on the x56. I have used the Logitech software to map different bindings when in Mode 2 and have saved this default profile. But when in the sim, nothing happens when i change to mode 2…ie. there’s no input response. Anyone know what I’m doing wrong or missing?


For whatever reason, I don’t think MSFS see the Logitech software. It seems to ignore it completely and talk to the controllers directly. I never got it to work. I just may my stuff in game.