MAJOR ATC-Callsign parsing bug for Offline AI

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes

Have you disabled/removed all your mods and addons?

Addons are needed to reproduce

Brief description of the issue:

When using an AI airplane with a registration (atc_id) that could be a valid flightnumer as well the internal ATC will call it with the parsed ATC callsign and not the correct one specified in the aircraft.cfg
Example 1: ATC_ID RPC4126 (Cebu Pacific Airbus) and ATC_AIRLINE CEBU, internal ATC will call for Aeropacsa. The airline using AEROPACSA has the ICAO-Code RPC.
Example 2: A Airplane in China with ATC_ID B-18905 does not get any callsign in the Sim, even if the ATC_AIRLINE is specified in the aircraft.cfg.
There are a few other examples for this issue.

Provide Screenshot(s)/video(s) of the issue encountered:

grafik
grafik
grafik

Detailed steps to reproduce the issue encountered:

Load offline/SimConenct AI with an ATC_ID that matches the ICAO code of some other airline.
Tested with AIG Traffic Controller based AI, thas worked fine before SU11 update.

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

SU11 Release


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

It was working fine on the final SU11 Beta build 1.29.25.0, this issue started with the SU11 Release build 1.29.28.0

If relevant, provide additional screenshots/video:

Images from October 31st on SU11 Beta showing correct callsign on right hand side



Screenshots from Today showing the wrong callsign/missing callsign Underlined text is the wrong callsign. The top one should be CEBU, bottom should be AIRPHIL.
Like Kaiii3 said, the sim appears to be seeing the tail number as a flight number and overriding the callsign with its own. ‘RPC’ corresponds with the callsign ‘Aeropacsa’
image
Aircraft registered to mainland China have no callsign at all. As shown above, they worked fine in the October 31st SU 11 Beta.
image
image

Same issue with a few airlines in Korea; Asiana, Korean Air, Air Busan, … they get called by their Airplane type and tailnumber instead of correct callsign and flight number.

Same issue for FSLTL in Taiwan. Almost every aircraft with Taiwanese B-XXXXX or Chinese B-XXXX reg fails to get the correct callsign.

Strangely, some traffic injected when you are on the ground does get correct callsign. I have two China Airlines correctly callsigned when I was on the ground.

Currently seen the following nationalities/registions problematic:

China (B-XXXX)
Taiwan (B-XXXXX)
South Korea (HLXXXX)

Currently seen the following nationalities NOT problematic:
Japan (JAXXXX, could be letter for the last two digits)
Hong Kong (B-XXX, letters instead of numbers)

It seems that this only happens to all-number nationalities?
Maybe some of us can try stay longer in Japan, because some older Japanese planes have number-only registrations. If we find out number-only Japanese planes are being callsigned according to tail number, then perhaps we have found the smoking gun.

Update: suspect found. When using FSLTL injector:
A Philippines plane got the correct call sign (Registration RP-C9918)
while
An ANA plane (ANA8442) got called Air Bosna (not tail number but still wrong callsign) (Registration JA8664)

So from these examples (found a “lettered” Philippine plane that works and a “pure number” Japanese that fail), I think it’s a fairly good guess that "Having a pure number (except nation prefix) registration is what triggers the bug.

And it gets better.
Guess what is the IATA symbol of “Air bosna (now B&H airlines)”?
It’s JA. The same as Japan’s registration prefix.

So this is the best hypothesis we have now:

When a traffic carries a registration that has only numbers in the “not nation prefix” part, the system takes the info as such:

JA8664 registration, ANA8442 ICAO flight number
becomes
JA8442 as a “proposed” IATA flight number.

And then this is compared with an IATA database. In this case JA = “Air Bosna”
so output is “Air Bosna 8442” (pay special notice to the fact that the flight number is correct, as well as the fact that “Air Bosna” is NOT a modern callsign, indicating it’s from MSFS’ own callsign database which is notorious for using outdated callsigns).

If there is no match, such as Taiwanese/Chinese planes with B- registration,
then the plane is considered not having a flight number and ATC understood it as “Boeing B-XXXXX”.

Considering the fact that FSLTL did change Eva Air’s callsign from “Eva” to E-V-A before, I think supposedly FSLTL should have a say on the call sign.
That means this “Air Bosna” incident would probably require MSFS to disregard MSLTL input to some extent (rather than just misinterpret it) and insert its own idea of IATA flight number.

1 Like

Please fix this . All my Korean air planes are called by their registration . It’s also happened to aer lingus for me and Asiana .

It’s “normal” (as in, as expected for this bug) for Korean planes to be called by registration (as Korea use pure number registrations).
Aer Lingus is strange, but maybe a confusion due to the fact that Aer Lingus’ IATA code coincides with Ireland’s national registration prefix (EI).

has anyone found a temporary fix for this? my brain is drying up from thinking of ways how to temporary fix it.

No. The bug is deeply internal and since it only happens on number-registered planes it’s hard to imagine Asobo, where most players are in letter-registered countries, will fix this anytime soon.

Is there any sign of this being remotely worked on? I’m getting sick of MSFS injection (backup choice as FSLTL injection has this bug) filling Taiwanese airports with VietJet or FlyScoot.

I can confirm the issue happens also with Colombian registrations (the format is HK-****, where each * is a number). I’ve just realized it now that I gave a chance to default ATC. It rarely happens with Avianca and Lan Colombia, since they use either N or CC registrations.

this bug is having issues with the number registrations as well since SU11, even my Copa flightplans calls “Boeing” reg number instead “copa” flight number :confused:

i even spotted a United 737 calls with a Boeing callsign instead of United

here the following registrations number were affected

  • HK-**** (Colombia)
  • HP-**** (Panama) (except planes ending with the ICAO code)
  • HL**** (South Korea)
  • P-*** (North Korea)
  • RA-***** (Russia)
  • B-**** (China) (Except newer planes)
  • B-15*** (Taiwan)
  • EX-***** (Kyrgyzstan)
  • OB**** (Peru)
  • YV**** (Venezuela)
  • JA**** (Japan) (some aircraft)
  • EK***** (Armenia)
  • UK***** (Uzbekistan)
  • N***** (USA) (some aircraft like United 737 fleet were affected)
  • V7-**** (Marshall Is.)
  • JU-**** (Mongolia)
  • ER-***** (Moldova) (some aircraft)
  • EY-***** (Tajikistan)
1 Like

I think it’s “except Hong Kong planes” because Hong Kong uses letter registration.

Yes because older Japanese planes use number registration while newer planes use number + letter.
For example
JA5579 (old, affected)
JA73AN (New, unaffected)

1 Like

well “Hong Kong and Macao planes” are unaffected but im talking with chinese planes registered post-2018 which are unaffected.

for example:

B-300A (Sichuan A321)
B-307C (Air China A350)

both unaffected since it has a letter

i found this on wikipedia

" Since 2018, the following registration schemes are also in use:

  • B-000A to B-999Z (General)
  • B-00A0 to B-99Z9 (General)
  • B-00AA to B-99ZZ (General)

In these schemes, the digit immediately after the dash is 2 for Boeing aircraft and 3 for Airbus aircraft. e.g.: B-20AC is a China Southern Airlines Boeing 777-300ER, and B-301D is a Sichuan Airlines Airbus A350-900."

1 Like

Has anyone checked if this has been fixed with SU12?

Nope :frowning:

Bug is still there

Unfortunately…this is still a persistent issue in the recently released SU13 as well…:(…C’mon Asobo…please get this sorted out

bump. Dec 24th 2023 the issue still persists.

Over on the devsupport forums, they’ve remarked they’re aware and working on it back in November 2022, and yet it’s March 2024 and still nothing. If it’s not fixed in MSFS2024 then that’ll be quite a disappointing sign.

Can anyone tell me if AIG has the same problem?

we are currently testing a internal fix/workaround and so far it seems to be working. An public update will be released in the next days

1 Like