Managed altitude does not work

Don’t get to work the managed altitude, the dot appears at the left side of the altitude (legacy/lock interface same result), but it does not follow the altitudes fixed in the flight plan and visible in navigator display and MCDU. It always follows the selected altitude by the knob. (A320neo, but also noticed in the 747 does not follow flight plan altitudes).
The follow of the waypoints/LNAV works correctly.
Tried uninstalling, erasing all folders, and fresh installing, but no luck.
Thanks

As far as I know you have to reach the altitudes requested by the ATC (which are not exactly the same as the flightplan) on climb and on descent by turning the knob. This on the default airplanes that I only fly.Cannot tell how it works on mods.

Reaching the ATC altitudes with selected altitude works well, but also I want the plane to fly the planned altitudes in the flight plan, with no ATC for example (A320 Asobo no mods)

In this video, the default A320, follows the planned altitudes, that’s what I want to achieve
https://www.youtube.com/watch?v=_d1TBaz7cBg

This video named " A320neo Autopilot follow flight plan and altitude (GPS Mode) - Microsoft Flight Simulator - Tutorial " could have been explained a little better IMO. Most of the comments to it are not of appreciation. The video is more than 17 minutes and he spent 3-4 seconds to explain ( great word if it works) how to engage the flight plan following clicking on HEADING too? Because of the title of this “tutorial” he should have spent minutes to explain how to. Unfortunately his pronunciation was not always understandable ,so my fault.In addition, the entire descent legs altitudes were all managed manually with the knob! Despite that I tried it ,unsuccessfully. If someone is able to do that and share it would be greatly appreciated.

I agree, the explanation is not clear, but the video shows that the autopilot respects the altitudes of the waypoints, and is the only video I’ve found in this subject (others tend to use selected altitude manually).
Maybe managed altitude worked when the video was made, and not now.

Yes ,the video shows that but I did not explain how to activate this mode.If you have understood that ,please let’s know.

Edit : I got it! If you activate AI PILOTING it works like in the video…lol.

AI Piloting what it does is follow the ATC indications automatically, answering ATC also,without any intervention, but not the programmed flight plan.

Yes,correct. It was the only solution I’ve found to see the altitude increase without using the knob. I have no other ideas .On youtube ,you can see that some people asked the author many key questions but it didn’t reply.

Managed Altitude works fine in the A320neo and uses the altitudes in the FMC and the flight plan. However, the flight plan has to be created using the World Map flight planner in order to have the correct altitudes and speeds for ATC and the FMC. However, flight plans created using a 3rd party flight planner do not have the altitudes and speeds in their flight plans. If you use a 3rd party flight planner, you will have to manually enter the appropriate altitudes. These FMC changes are not uploaded to MSFS ATC as of SU9.

Note: There are some 3rd party aircraft that do not use MSFS-created flight plans including altitudes and speed restrictions.

I have tried with creating the full plan in the ingame planner, and also importing Simbrief plan, and the results are the same, don’t know where the problem could be.