Many live traffic aircraft despawn at and around airports (1.37.8.0)

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Which aircraft are you using that experiences this issue?

not relevant

Brief description of the issue:

While monitoring aircraft on ground it seems there are currently many despawns happening in the following situations:

  • during approach
  • on and after takeoff
  • on taxi out
  • at the gate
  • on the taxiway (after landing and on their way to the active runway)

This makes busy airports feel empty after some time, so something on the removal algorithm introduced on the last beta seems too aggressive.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

  1. Spawn at some busy airport like LAX or LAS
  2. Watch traffic for 20 minutes, follow them leaving gates and on landing
  3. Most likely many despawns will be discovered during that time, airports won’t seem that busy because of this

PC specs and peripheral set up:

Are you using DX11 or DX12?

DX12

Are you using DLSS?

DLAA


:loudspeaker: For anyone who wants to contribute to this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

Are you using DX11 or DX12?

Are you using DLSS?

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

At EGLL using the drone I noticed exactly the same thing following planes on landing and take off disappearing either halfway down the runway or not long after take off.

Are you using DX11 or DX12?

Xbox

Are you using DLSS?

Xbox

If relevant, provide additional screenshots/video:

Sometimes it seems aircraft reappear after um to 10 seconds, especially if they disappear on approach leading the same aircraft to land again and disappear again.

I had a scenario yesterday where it had at least 12 all head out of the gate at once. First one inbound landed, turned at high rate of speed and went right through the terminal. Then it was carrier ops takeoffs, another came in no issues. Then another was called in on final and sat in the approach like a UFO for 10 minutes until everything else left. After that, zero traffic. This was at DCA. They all took off on the unused 04 and flew straight over Washington DC. Was just letting the airport run in it’s own while playing with my daughter. I was 15’ from a blank traffic sign.

DCA was predictably accurate in the last build. Using 19/01. I bounced out of this beta build for now. 07 is the worst build I’ve seen ever

Situation continuous on 1.37.8.0 - most landed aircraft disappear before reaching their gate.

1 Like

Currently checking the situation on 1.37.9.0: seems the situation has been improved :slight_smile:

  1. at least some aircraft reach their gates again after landing, however they tend to despawn just before entering it
  2. most aircraft make it to the runway
  3. airports are nicely populated (looks like more flights are taken into account)

Some impression:

It seems that while situation on US airports is way better on European airports ist’s still like on 1.37.8.0 and 1.37.7.0 - so despawns happening early might relate to either caching on server side or data quality available on other regions across the globe.

I checked EDDF which should be used quite frequently today but aircraft despawn already on the runway after landing.

It’s not any better at US airports and were now at build 1.37.9.0

I think the first build showed some promise but everything after has been a waste of time regarding Live Traffic in my view. I don’t even attempt to use/test anymore.

Not only that but at least from my perspective traffic now generates an large amount of stutter and pause in the sim. Without traffic Beta 15 is very good performance wise. Turn on any form of traffic, sim, FSLTL, AIG and that performance goes away. To be fair it has always been this way but to me it is MUCH worse in 15 so far.

Sad part is FSLTL traffic is showing some of the sim traffic characteristics now. I only hope they can resolve them.

2 Likes

Have the same conclusion. It’s not ready to release but they’ll do it anyway and this will be pushed to another su update.

1 Like

Still present in SU15B v1.37.12.0. This is at Albany (KALB), Notice how the taxiing orange aircraft vanishes in pic #2. It got as far as the Rwy 19 hold-short point, then vanished as another aircraft approached on final. This aircraft also vanished as it was about to turn off the runway after landing:

Partial Specs & settings:
Build: SU15B v1.37.12.0
3rd-Party Addons: None, Community Addons: None
Flight configuration: Multiplayer: All Players. Traffic: Live, Weather: Live
i7-12700K (No overclocking), 32 GB 5200 MHz DDR5 CL40, Arc 770 (16GB, v31.0.101.5333).
Graphics Tab: TAA, Render resolution 1700x960 @ 125, AMD Fidelity - 150, VSync - On, FRL - 100% MRR (60 Hz), HDR10 - Off, DX12B, TLOD @ 250, OLD @ 200, Motion Blur - Off, Other settings - all Ultra (Water Waves & Glass Cockpit Refresh Rate @ High).
Traffic Tab: Aircraft Traffic Type - Real-Time Online, Slider Settings - All 100%, Generics (AI, MP) - Both Off, Show MP in Vicinity - On, Traffic Variety - Ultra
Data Tab: Data Connection: All six options - On, Data Limit - Off, Bandwidth - Unlimited, Rolling Cache - Off
Developers Tab: Developer Mode - Off
MSFS Version: MS-Store, Standard, plus All WUs & City Updates.

2 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

It happens from SU 15 update

Are you using DX11 or DX12?

DX12

Are you using DLSS?

NO DLAA

If relevant, provide additional screenshots/video:

Live traffic almost disappears on approach phase. Planes icon stay freezed in VFR map fopr minutes after planes disappears.

The plane in the circle immediately before disappearing at LIMF

The plane in the cirle immediately after is no more there!

The VFR Map show a frozen plane icon where it was disappeared. It stay there for minutes.

After SU15 I have the same problem
Sometimes they land but shortly after they disappear while taxiing to the gates.
Also tried with FSLTL injector, and the problem stops

1 Like