Many POIs have disappeared in world map

hello everyone

I have just noticed that many POIs have disappeared in the world map. the landmarks in New York city to name a few.
does anybody observe the same issue? did i miss something?

thanks in advance for your feedback

`Do you have any add-ons in your Community folder? no

Are you using Developer Mode or made changes in it? no

Brief description of the issue: it seems that many POIs have disappeared in the world map

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  • go to world map
  • zoom in the New York area
    BUG: most of landmarks are missing (statue of liberty, empire state building, governor island …)

PC specs for those who want to assist (if not entered in your profile)

Build Version # when you first started experiencing this issue: 1.17.3.0

Are you on the Steam or Microsoft Store version?microsoft store version

Did you submit this to Zendesk? If so, what is your ticket #? no

Yip I have had that… It also annoys me that I keep having to turn on certain filters when I have done so a 100 plus times already!

1 Like

You can install this if you want your POI back.

1 Like

Once you visited a POI, it disappears

i don’t think so. i have visited plenty of POIs in France: there are are still there.

I’m starting to think these POI are seasonal. Like they appear for the most recent World Update. But once they’re too far back they disappear from the map.

Just like those activities mode which are seasonal.

for your information it was a real bug and it has been fixed within the sim update 5.

1 Like

I had the POIs before the July 27th update. Now the markers do no load despite have then turned on in Assistance .

It has not been fixed, and in fact the problem is now worse than before.

1 Like

My FS2020 is up to date and several POIs hava disapeared. The Reichtag, in Berlin (there is a banner in the place, but the building is not there), TV tower in Berlin, Coliseum in Rome, Sagrada Família Church in Barcelona, Prado Museum in Madrid and so on. Even after the last update the problem continues.

my FS2020 is also up to date: Reichtag and Berlin Telivision Tower are there as POIs and as buildings.

and as far as i know coliseum, sagrada familia and prado musueum have never been POIs in the out of the box FS2020 version. buildings are there but not listed as POIs yet. those European regions have not yet been part of any world updates.

your issue is maybe due to some mods overriding the official world updates.

Thank you CFHangar 18! I think I’ll have to uninstall and reinstall the game to fix the problem.

Does anyone knows if there is another way to fix it?

First you should ensure that no update is still pending in content manager. If the issue is still not fixed you should then try to uninstall all the add-ons you may have installed on top of FS2020.

There is no update still pending in content manager and no add-ons in Community folder.