Marketplace Buy buttons grayed out

I had a problem a couple weeks back that every time I tried to purchase something the steam overlay failed to come up and the purchase just hung there. Figured out it was “FRAPS” causing the problem. Got rid of it and the purchase worked.

No today I went to buy something but the buy options are inactive. I searched here and the net and tried lots of stuff with no luck.
Made sure not to run as admin
Turned data on and off in the game
Turned off data limit amount.
None of that worked. I still think that may be the problem but I cannot figure out how to reset the limit or the amount downloaded.
Any ideas would be great.

1 Like

@brlowe1965, you might try clicking on your profile / avatar and chose Sign Out. Exit the sim. Then go to the start menu and launch the app titled “Xbox” and when it comes up, launch MSFS using that icon.

(Not sure if that last step is necessary, but that has worked for others. May be different if you have the Steam version)

The log out and back in was the first thing I tried. Did not work but I thought it would.

I had the same problem with my steam version once and ended up restarting my computer and then MSFS and everything worked fine.

Reboot did not help but thanks for the suggestion. I’m stuck at this point.

Just to be clear I can get into the Marketplace, I am logged into my Xbox/MS account and the problem is the buy buttons are not active.

Maybe there is an issue with your Payment method ??
Expired CC ? or whatever

LOL at least we all think the same way. When I purchase it opens the steam overlay and completes the purchase there. I use Paypal and I tested it in steam yesterday by adding money to my steam account from inside steam so that is not the issue but like you I thought it might be and tried it. I also used Shift-Tab to open the overlay from the Marketplace window to make sure that was working and it is.

Also I purchased CyberPunk 2077 in steam 3 days ago so it works for sure.

If you don’t already have it, see what the free Paderborn package looks like in your Marketplace.

I do not have that free package so I just went to the market and it is the same thing, I cannot click on it to buy and download.

Try logging out from within the XBox Game Bar, then start the sim and log in. If that doesn’t fix it, then report it to Zendesk.

I tried logging out of Xbox game bar and then starting FS2020 and then logged in and this made no difference, still broken

Yep - time for a Zendesk report…

I have a request in with them and they focused on my Steam Overlay which opens just fine. Told them it works fine but have not heard back from them. Best part is the steam overlay does not come into play until you press the buy button and I cannot even do that. So they need to focus on why the buttons are not active.

I have the same problem … now.

I used to have “clickable” Buy butons in the marketplace. I was able to “buy” the free Paderborn airport.

Then I did (try to) buy an airport a few days ago. The credit card transaction completed and the money has been charged at my bank account …

… but … the download failed and I received a number of “bell” alerts in the game that the “purchase failed”. Since then … whenever I start the game the “buy” buttons in the marketplace are no longer clickable.

This looks like a bug to me.
Should this be moved into the “bug” section?


Market place buy buttons are grayed out and not working for me also. I reported to Zendesk and they sent me 3 things to try and marked it solved. None worked. I added to that ticket and eventually sent a new one and haven’t heard a thing since. I have tried everything including removing and re adding my payment method (PayPal) except a reinstall. Can’t even download the free items. Very frustrating.

I had this issue for a while and finally found it was another program causing the problem. In my case it was “FRAPS” which is a frame counting program that runs in the backgound.
What I did was to stop everything from loading at start up and I mean everything. Go to task manager and on the Startup tab make note of what is starting and disable everything you can. If the system will fail without then do not disable it but I think everything there can be disabled.
Then reboot. After reboot check your system tray by the clock and make sure nothing is running. If something is running close it. I would go ahead and copy everything out of your community folder too but I do not think this is it.
Now start flight sim and see if the buy button is working. If it works you can start putting things back into start up and retest until you find what is causing the problem. This whole process my require a lot of reboots and take some time. I got lucky and found my problem on the first program I tested.
If none of this helps I’m sorry as I do not know what to do to help you.

Thank-you kindly for trying to help with this. I tried your procedure but unfortunately the issue still persists.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.