Marketplace purchase is pending -- nothing happens

On XBox, the only way you can purchase things is via the Marketplace. I never had an issue on XBox.

I’ve since moved to PC. For 2 of the last 3 purchases, I have had this happen. I go and look at an item. It shows me all the info, and all the images perfectly fine. I then go to purchase. It pulls up a list of my credit cards, asks me to select which one, and then authorizes. And IMMEDIATELY after it authorizes, the screen clears, you go back to the main menu, and you get an announcement that you are offline. And you have to wait a few minutes until you come “back online”. And once you do, then it keeps trying to reauthorize again, and gets stuck in a loop.

The only way to clear this is file a zendesk ticket. You fill in all the information into the ticket, but the text for the incident doesn’t have most of that information you entered. So then you will get an email back stating you need to supply a bunch of other information (which you did when you filled out the ticket). And then you wait for resolution.

The sad thing is, I’m stuck with a transaction, and that is blocking me from even getting the World Update, because even though it is free, you have to “purchase” it in order for it to become something you can download. And of course with a stuck purchase, I can’t “purchase” the world update.

Just a note, this isn’t related to the slow download incident. People have determined the slow download is happening on the east coast users because of a bad Bell router in the IP route. So I always set through VPN now my location to Chicago when I am using MSFS.

Microsoft gets 30% of the sale through the store. I figure that helps with keeping the sim going. But seriously, if 66% of the time it is going to fail and I am going to have to fill out tickets and spend days getting this cleared up, I’m likely to only use the store for MS exclusives like Carenado, the Asobo DLC, and World Updates.

1 Like

Same here from Canada and doubled checked everything… Purchase failed purchase pending… yet the transaction shows as completed in my account on the store.

Still nothing after logging in and out and rebooting. Just stuck in an error loop. Ticket submitted with Zendesk…

Can someone please fix this. I can’t download the world update nor the content I paid for now.

Same problem here! Send a ticket to Zendesk and hope they will react…!

I have the same problem!

Same issue here, tried to buy LEBB by BMW…and now I can’t get it or the U8…all greyed out…;(

For those having issues with a marketplace purchase, please see one of the FAQ topics in support relating to your client:

https://flightsimulator.zendesk.com/hc/en-us/search?utf8=✓&query=Purchase&commit=Search

Instructions are there as well as who to contact if you are unable to resolve it.

1 Like

I had the same issue for a Carenado plane, but I managed to buy it.

For Steam users:

You can try to first check if overlay is enable inside Steam settings, after that launch MSFS and disable “devmode” if it’s on and select windowed mode in the settings, then close MSFS and launch it with Steam in the library not a shortcut.

Maybe it can help someone doing it that way.

1 Like

This solution worked for me, by following this instructions I was able to make my purchase.

Thank you!

1 Like

Okay, even with Steam Overlay checkbox es enabled in both places on my steam app (“Steam”, “Settings”, “In-Garme” from Steam main page and “Settings”, “Properties”, “General” MSFS 2020 pulled up in the Library), this was happening to me as well using a high end Alienware PC. I did 3 things.

  1. I put $25 in my Steam account from the Steam program because I didn’t trust the reliability of the interface with PayPal because I had had problems with it in the past purchasing a plane but not downloading.
  2. I changed the properties of Steam.exe and GameOverlayUI.exe in folder “C:\Program Files (x86)\Steam” to “Run as Administrator”. Note: When Steam started up it warned me to not use compatibility mode but I left it on anyway.

I could not purchase the Top Rudder 103 Solo on April 5, 2022. I did the two settings above on April 6, 2022, and still got the “Purchase is Pending” multiple times as I tried shutting down and restarting MSFS 2020 multiple times. I even tried temporarily shutting off Malwarebytes anitvirus program.

  1. I had 3 external monitors connected besides the main monitor I use for MSFS 2020. I decided to disconnect all 3 of the external monitors leaving only the main monitor connected.

Today, April 7, 2022 doing all 3 steps above, I decided to give it another try. I even left Malwarebytes active. It finally worked. I was able to purchase download the Top Rudder 103 Solo as the Steam Overlay finally worked.

Conclusion: I don’t know if the monitors were the issue for sure or not as I read one post where it didn’t work and then mysteriously worked. I wish I would have tried purchasing today before disconnecting the other monitors but unfortunately I didn’t.

I disconnected the additional monitors because I had a rather obscure problem with multiple monitors causing a failure when trying to install “OculusSetup.exe” on my computer so I could do VR with my Oculus Quest 2. I tried for over a month installing the “OculusSetup.exe” program on my computer. Nothing worked to get rid of the installation failure until I disconnected all but one monitor.

Just saying, using only one monitor might help.

Hello,
I’ve got the same problem. I’m on Xbox Series X. Today I bought almost 10 items from Xbox marketplace without any problem(!) finally I wanted to buy The Airport Islamabad and there i got my problem. I have paid by PayPal. I got the reciep from PayPal, so it’s paid. But i can’t download Islamabad Airport. I’m getting that message what you guys said here before. Trying and trying downloading but nothing happens. It’s payed already by pp.

1 Like

Hi @SCHIESSBURGER,
Please see this post above for issues with purchases:

I think PayPal has a transaction limit but if you received a receipt, then follow the instructions above to contact Zendesk.

1 Like

Got the same problem. I was charged (bought with paypal) but the order is still pending and then it fails. Can’t buy anything else. Submitted a ticket to zendesk but got no answer yet.

1 Like

Same issue for me. Marketplace works fine taking the money…then hangs up my account with “purchase pending” and “purchase failed” notifications. Huge amounts of “help instructions” all over the place, which are either not applicable or don’t work. Just stuck in an error loop as experienced by others. Seems a common feature with this Sim, visually appealing “facilities” which don’t actually work. I have only used the marketplace once before for third party software which was incomplete and second rate. I await action from Zendesk…

2 Likes

I was having this issue on my pc version, and here’s what worked. Logged out of Xbox app and MS Store app. Rebooted and logged back in to both apps, then opened sim. I was then able to make the purchases without issue.

1 Like

Same here, I tried everything and at Zendesk there is nobody, the office is empty.

1 Like

Have the same issue. Contacted Zendesk, nothing yet. Did contact xbox and windows support. They recommended resetting / reinstalling the game. After the download of over 120 gigs problem still persists.

That happend on my PC. Today I tried the game on the xbox. Same issue! This game…

Waiting for zendesk to get this sorted.

1 Like

For those that have contacted Zendesk and it’s been over a week (business days), send a DM to @Jummivana with your Zendesk ticket number.

2 Likes

I sent this to Zedesk to prompt them regarding my ticket:-
Hello Zendesk

Please indicate when I can expect my account to be unlocked from a ERROR “purchase is currently pending” banner and “purchase failed” and “purchase pending…Switzerland Mesh purchase is pending” notifications which I cannot cancel.

I cannot sign out of my account and back in…the Sim restarts to the above state and then runs as normal…so I cannot reset it myself, whatever your “help” instructions say.

The “Marketplace” is locked out, on “another transaction pending”…

re the instructions below…

I will not supply a pdf of my bank statement on privacy grounds. (my privacy that is)…if such proof is required you can keep the payment with my compliments.

In any event the transaction will no doubt need to be cancelled and I will not attempt to use the Marketplace again.

yours etc

I received a response today and the issue is now resolved…
They are trying !

1 Like

I had this issue. Account log out did not resolve so I opened a Zendesk ticket. They resolved it promptly (within 48 hours - which I think is pretty darn good)

1 Like

Have the same problem, the sad thing is, the sale ends tomorrow 🥲

2 Likes