Marketplace purchase is pending -- nothing happens

When I want to buy a plane (steam version) market place, I get stuck after clicking buy or buy and download. Even downgraded from su8 beta to normal. No solution. Same behavior.
Tried logout from store, logout from sim, both relogin, same.
What is wrong?

… purchase is pending.

It still is. Very frustrating.
Off topic… Bushtrips are a mess. Have to fly them over and over again, still with every update lose all progress, lose navigation points etc. Tried the workarounds, that flies, but then it misses out on accomplishments. Landing challenges etc.
Product still in beta alltogether I wonder??
Pffff. That said. Still a lovely product, and trying to expand the experience. How to accomplish this?

I have Steam – here’s what I have to do:

Open Steam, go to Settings
Click the In-Game tab to verify that ‘Enable the Steam Overlay While In Game’ is checked
Go to the Library, select the game, and under Properties make sure it’s checked there too
Start MSFS, go to Marketplace, and try again
You should get the Steam pop up to allow purchase to go through

If that’s not it, sorry. Best of luck.

2 Likes

Thank you very much. That’s the way to proceed!

I have normal Microsoft store version. Have the same problem

4 Likes

hi all i managed to sign out of my account and sign in - do the same for xbox app and microsoft store app, and this fixed the issue

same issue, sign out and in (safe mode+normal mode) does not help :confused:
EDIT: 3.3.2022 is OK, no problem :slight_smile:

Same problème here and buy MSFS on Microsoft store. I have tried everything and nothing solved the problème when i click on buy and download nothing hapened and a red notice said that an other transaction is pending !!

2 Likes

Same problem here but I haven’t had a chance to try any of the above.

I am having same issue as Flakeyhawk4900 and I’ve reset everything and still says another transaction is happening. Anyone have any suggestions on what I should do

2 Likes

same issue i am in Australia, managed uninstall xbox app then reinstall it , i managed to buy a plane then next day wanted buy another no go, tried resetting ,repair app, sign out and in xbox,nothing .come on Asobo fix this .I am on pc

ok guys ,

when you redeemed your voucher to add to your flightsim credit before the amount will say 020 or 060
I have AU$28 says 060 .I think need to have over $45 to $50 to get to the 120 credit to make perches.I could be wrong.When i get paid again I top up and see .

same here in NZ - bought an orbx add-on, paid via paypal , transaction still pending after 24hrs. signed off and on again, to no avail. The add-on wasn’t expensive but until this is solved, I can’t buy anything else on market place…

2 Likes

Open a ticket on Zendesk, they would fix your purchases personally. I have had the same issue, and they solved all my requests regarding to MarketPlace purchases.

2 Likes

On XBox, the only way you can purchase things is via the Marketplace. I never had an issue on XBox.

I’ve since moved to PC. For 2 of the last 3 purchases, I have had this happen. I go and look at an item. It shows me all the info, and all the images perfectly fine. I then go to purchase. It pulls up a list of my credit cards, asks me to select which one, and then authorizes. And IMMEDIATELY after it authorizes, the screen clears, you go back to the main menu, and you get an announcement that you are offline. And you have to wait a few minutes until you come “back online”. And once you do, then it keeps trying to reauthorize again, and gets stuck in a loop.

The only way to clear this is file a zendesk ticket. You fill in all the information into the ticket, but the text for the incident doesn’t have most of that information you entered. So then you will get an email back stating you need to supply a bunch of other information (which you did when you filled out the ticket). And then you wait for resolution.

The sad thing is, I’m stuck with a transaction, and that is blocking me from even getting the World Update, because even though it is free, you have to “purchase” it in order for it to become something you can download. And of course with a stuck purchase, I can’t “purchase” the world update.

Just a note, this isn’t related to the slow download incident. People have determined the slow download is happening on the east coast users because of a bad Bell router in the IP route. So I always set through VPN now my location to Chicago when I am using MSFS.

Microsoft gets 30% of the sale through the store. I figure that helps with keeping the sim going. But seriously, if 66% of the time it is going to fail and I am going to have to fill out tickets and spend days getting this cleared up, I’m likely to only use the store for MS exclusives like Carenado, the Asobo DLC, and World Updates.

1 Like

Same here from Canada and doubled checked everything… Purchase failed purchase pending… yet the transaction shows as completed in my account on the store.

Still nothing after logging in and out and rebooting. Just stuck in an error loop. Ticket submitted with Zendesk…

Can someone please fix this. I can’t download the world update nor the content I paid for now.

Same problem here! Send a ticket to Zendesk and hope they will react…!

I have the same problem!

Same issue here, tried to buy LEBB by BMW…and now I can’t get it or the U8…all greyed out…;(

For those having issues with a marketplace purchase, please see one of the FAQ topics in support relating to your client:

https://flightsimulator.zendesk.com/hc/en-us/search?utf8=✓&query=Purchase&commit=Search

Instructions are there as well as who to contact if you are unable to resolve it.

1 Like

I had the same issue for a Carenado plane, but I managed to buy it.

For Steam users:

You can try to first check if overlay is enable inside Steam settings, after that launch MSFS and disable “devmode” if it’s on and select windowed mode in the settings, then close MSFS and launch it with Steam in the library not a shortcut.

Maybe it can help someone doing it that way.

1 Like