Marketplace purchase is pending -- nothing happens

This solution worked for me, by following this instructions I was able to make my purchase.

Thank you!

1 Like

Okay, even with Steam Overlay checkbox es enabled in both places on my steam app (“Steam”, “Settings”, “In-Garme” from Steam main page and “Settings”, “Properties”, “General” MSFS 2020 pulled up in the Library), this was happening to me as well using a high end Alienware PC. I did 3 things.

  1. I put $25 in my Steam account from the Steam program because I didn’t trust the reliability of the interface with PayPal because I had had problems with it in the past purchasing a plane but not downloading.
  2. I changed the properties of Steam.exe and GameOverlayUI.exe in folder “C:\Program Files (x86)\Steam” to “Run as Administrator”. Note: When Steam started up it warned me to not use compatibility mode but I left it on anyway.

I could not purchase the Top Rudder 103 Solo on April 5, 2022. I did the two settings above on April 6, 2022, and still got the “Purchase is Pending” multiple times as I tried shutting down and restarting MSFS 2020 multiple times. I even tried temporarily shutting off Malwarebytes anitvirus program.

  1. I had 3 external monitors connected besides the main monitor I use for MSFS 2020. I decided to disconnect all 3 of the external monitors leaving only the main monitor connected.

Today, April 7, 2022 doing all 3 steps above, I decided to give it another try. I even left Malwarebytes active. It finally worked. I was able to purchase download the Top Rudder 103 Solo as the Steam Overlay finally worked.

Conclusion: I don’t know if the monitors were the issue for sure or not as I read one post where it didn’t work and then mysteriously worked. I wish I would have tried purchasing today before disconnecting the other monitors but unfortunately I didn’t.

I disconnected the additional monitors because I had a rather obscure problem with multiple monitors causing a failure when trying to install “OculusSetup.exe” on my computer so I could do VR with my Oculus Quest 2. I tried for over a month installing the “OculusSetup.exe” program on my computer. Nothing worked to get rid of the installation failure until I disconnected all but one monitor.

Just saying, using only one monitor might help.

Hello,
I’ve got the same problem. I’m on Xbox Series X. Today I bought almost 10 items from Xbox marketplace without any problem(!) finally I wanted to buy The Airport Islamabad and there i got my problem. I have paid by PayPal. I got the reciep from PayPal, so it’s paid. But i can’t download Islamabad Airport. I’m getting that message what you guys said here before. Trying and trying downloading but nothing happens. It’s payed already by pp.

1 Like

Hi @SCHIESSBURGER,
Please see this post above for issues with purchases:

I think PayPal has a transaction limit but if you received a receipt, then follow the instructions above to contact Zendesk.

1 Like

Got the same problem. I was charged (bought with paypal) but the order is still pending and then it fails. Can’t buy anything else. Submitted a ticket to zendesk but got no answer yet.

1 Like

Same issue for me. Marketplace works fine taking the money…then hangs up my account with “purchase pending” and “purchase failed” notifications. Huge amounts of “help instructions” all over the place, which are either not applicable or don’t work. Just stuck in an error loop as experienced by others. Seems a common feature with this Sim, visually appealing “facilities” which don’t actually work. I have only used the marketplace once before for third party software which was incomplete and second rate. I await action from Zendesk…

2 Likes

I was having this issue on my pc version, and here’s what worked. Logged out of Xbox app and MS Store app. Rebooted and logged back in to both apps, then opened sim. I was then able to make the purchases without issue.

1 Like

Same here, I tried everything and at Zendesk there is nobody, the office is empty.

1 Like

Have the same issue. Contacted Zendesk, nothing yet. Did contact xbox and windows support. They recommended resetting / reinstalling the game. After the download of over 120 gigs problem still persists.

That happend on my PC. Today I tried the game on the xbox. Same issue! This game…

Waiting for zendesk to get this sorted.

1 Like

For those that have contacted Zendesk and it’s been over a week (business days), send a DM to @Jummivana with your Zendesk ticket number.

2 Likes

I sent this to Zedesk to prompt them regarding my ticket:-
Hello Zendesk

Please indicate when I can expect my account to be unlocked from a ERROR “purchase is currently pending” banner and “purchase failed” and “purchase pending…Switzerland Mesh purchase is pending” notifications which I cannot cancel.

I cannot sign out of my account and back in…the Sim restarts to the above state and then runs as normal…so I cannot reset it myself, whatever your “help” instructions say.

The “Marketplace” is locked out, on “another transaction pending”…

re the instructions below…

I will not supply a pdf of my bank statement on privacy grounds. (my privacy that is)…if such proof is required you can keep the payment with my compliments.

In any event the transaction will no doubt need to be cancelled and I will not attempt to use the Marketplace again.

yours etc

I received a response today and the issue is now resolved…
They are trying !

1 Like

I had this issue. Account log out did not resolve so I opened a Zendesk ticket. They resolved it promptly (within 48 hours - which I think is pretty darn good)

1 Like

Have the same problem, the sad thing is, the sale ends tomorrow 🥲

2 Likes

Well I’m glad it’s being handled I’m just sad cause I really wanted to fly the 777 and sale does end soon :weary:

1 Like

The CaptainSim one? Count yourself lucky! (PS welcome to the forums)

Same issue…again!

Same issue

so what I did to fix this is right after I click on ‘Buy and Download’ button I manually open Steam overlay myself (SHIFT+TAB is default) then it gives you way to add funds via Steam Wallet and it works

emphasized textThis topic has not been solved for everyone. I do not use Steam to purchase anything from the market p[lace. I have been locked out of the market place for more than 2 months now and I am really angry that I cannot take advantage of the sales and other offerings there. I know that I can purchase almost everything direct from the developer and install them myself but that doesn’t repair my lockout.

I, too, have been locked out for several weeks (PC store). The first post here was last February so this problem is five months old. Apparently only a few users are impacted so this is probably a very low priority bug. It could be that this bug cannot be duplicated.

I suppose I can wait for SU10 rollout to see it there is a fix since there wasn’t a fix in SU9.