Menu - GPU High Temps ??

Has anyone else notice this, or had the same issue.

  1. If I’m in the sim with any aircraft my GPU temps are normal between 125 - 145.

  2. But as soon as I exit into any part of the menu, the temp of my GPU climbs (quickly), and will stay at 172 - 176. When I exit and go back to flying, then the the drops dramatically.

I mean the GPU should be getting it hardest workout when you’re in the Sim, and flying around, as the framerates are around 52 average. Then they go sky high when I enter the menu, meaning the GPU should not be taxed as hard when there is no scenery that is not being constantly being drawn.

1 Like

I saw something similar.

My son was flying and I told him to quit when he was done but heaccidentally left it at the MSU menu for 2hrs.

You could have fried an egg on my glass case…

Switch vsync on, should help.

3 Likes

Correct, without Vsync the GPU will try its best to get maximum framerates in the menus.

It kind of funny that Max frames set to 60, yet in the menu it goes way beyond 60.

I turned Vsync on, and it barely made any difference, still reaching 171 degrees. More like something that needs to be addressed by Asobo.

that’s odd. For me when I set vsync to 60, it’s on 60 in the menu’s as well, and it stays nice, cool and quiet.

Are you sure your video drivers aren’t overriding the sim? (Nvidia Experience?)

I don’t use Nvidia Experience, its not installed.

They did not mention whether they have an Nvidia or AMD GPU. For example, in the Nvidia control panel vsync should be set to application driven. AMD also has a corresponding control panel. It is important that it is set to application controlled in the driver.

Use RivaTuner that comes with Afterburner to cap your frames at 30fps (for example), then it will be ok. I can even turn off VSYNC with it. :small_airplane: :smiley_cat:

I think this issue if you want to call it that has been around since beginning. The video cards working hard even in menus. I know such was the case even when installing the freaking game, there was no reason for the GPU to be cranking during install process. I think they fixed that couple patches ago. I think they also did some tuning to tame the GPU usage when in menus but in my opinion it’s still a bit high.

I think when you’re actually flying, your GPU usage is fluctuating depending on scenery with “breaks” in between so the GPU temp fluctuates up and down more. But in menu it’s a constant load and I have no idea why.

Hopefully Asobo addresses this issue again and does something about it but as it stands, I don’t think there is anything abnormal with your system. It’s just how it is right now.

Just letting you know that when I re-enabled Vsync that my GPU usage went down as well as the heat whilst sitting in the menu. It does appear to be the solution that many of us are using. Have you had any luck since?

Running a RTX 2080, patches have changed nothing, card still runs way to hot in Menu’s, runs the exact same high temp now, as when MSFS launched. Vsync on or off makes no difference. Since no other game has “ever” done this, I take as a programming flaw.

Alex if you would have read my reply right above your post “I don’t use Nvidia Experience, its not installed”. Statement basically states I’m running a Nvidia card.

Two of my other favorite games, American Truck Simulator and Euro Truck Simulator 2 also do it. It’s part of why I use RivaTuner to cap fps.

But I’d like to see it fixed, too, for all of them. :small_airplane: :smile_cat:

I think Asobo should shift to vsync ‘on’ when you are in the menu system, then back off or what you have set it to when playing game. My GPU goes from 99% to 50% when I have gsync on while I’m in the menu system.

1 Like