Microsoft sidewinder precision pro joystick not compatible

Hi all, Love the game but was really disappointed that my joystick which I’ve been using since FS2004 no longer works.

I realise it old but can’t understand why it’s any different to any other joystick on the market. It’s a microsoft sidewinder precision pro 2 it works perfectly for FSX but not FS2020.

Any ideas what I can do apart from buying a new one? I have already tried to configure it but with no success.
After little bit of google it looks like I’m not the only one who has this issue.

Many thanks



Don’t understand. I’m using one. Love it.

I’m also trying to use a Sidewinder Precision Pro 2 and it does not work at all. Is recognized but I can’t get the dang thing to map. Any help?

1 Like

Have you tried another stick to test the install?

I used mine during the alpha and beta stages and it works fine on the release version. Problems seem to involve binding rudder, ailerons and elevators the wrong way. Correctly done they should look like this;
You will probably need to set dead zones for better control once all is working. Hope this helps.


Yes, some bindings are backward, and some seem to change between planes. the 787 revrses my views in the tophat!

Would it be possible to show a picture of how you got the slider to work on microsoft sidewinder precision 2 please, i am able to map the slider to the throttle and i can see the white bar moving in the mapping page,but when i get in game it just wont work, i can map it so it works half way on the slider, but cant go from full throttle (slider up position) to no throttle (slider down position), i will only work if i have the slider set at half way on the joystick, so half way then up, throttle increase, half way then down decreases throttle, not accurate at all.

On mine the white bar jumps back and forwards in an incoherent fashion. However, it still works correctly in the sim. BTW, it needs to use ‘reverse axis’ button

I have mapped 2 throttles so I can use the A320.


yes thanks to profsc410 for pointing out to use THROTTLE AXIS 1 option, and it worked,thanks for the help lads

Please can someone tell me how I find the throttle axis setting> I did see it before i started trying to make my joystick work so i could use the throttle (also a Sidewinder) but it seems to have disapeared, all i see now with throttles is increase and decrease throttles.

I can’t get my Sidewinder Precision Pro to map. Yes, I have had it forever, but it still works perfectly. I had to make my first flight using an X-Box controller, which was horrible. Are there any websites with community made presets?

1 Like

The pictures on posts 4 and 8 on this thread should get you started on your Sidewinder. I have the same ancient joystick and it is working just fine with the sim. Make sure you have ‘ALL’ selected below the filter to see all the options in the pictures. Hope this helps.

Thanks for the information. I had set the joystick to the correct inputs last night, but when I tried running through the first tutorial, it was still using the Xbox controller. I double checked what you had, plus added a few more functions, saved, quit the program, came back in and it went back to the XBox. Any idea on how to change the default controller to the Sidewinder?

Hi guys,

Thank you for helping me sort my sidewinder out

Hey all a massive thank you to all, it’s so much better to have my original joystick back :slight_smile:

Here’s what I’m doing for controls, mostly the same as above but I’m flying in third person (mostly so I can look at the scenery easier with my mouse.)

Isn’t that assigned to Aieleron Axis X