Missing input/lag TCA Throttle Quadrant

Hi, a couple of days ago I got my tca airbus throttle quadrant, I’m having a big issue which makes the sim unplayable, using the default profile I noticed that all aircraft tend to miss some of my throttle input, for example, if I move the throttle lever to the toga position the aircraft won’t register that input, in which I had to try several time to make the aircraft register my command which makes the sim completely unable with my throttles. I tried to make adjustments to the profile but nothing seems to work, even the default profile.

To make sure my unit is not faulty I tried the same in xplane and seems to work smoothly without any issues.

You can’t really change the default profile, because they serve as a restore point when you make mistakes in the bindings.

When you make changes to the default profile, it would ask you to duplicate into a separate profile. So any changes that you made actually saved to that new profile, not the default.

As for how it registers the input. What aircraft are you using it with? Are you on Default A320, or FlyByWire A32NX aircraft, or other generic prop aircraft.

The default profile is set to work for the sensitivity curve of the Default Asobo A320 aircraft. Meaning the curve changes depending on the area of the throttle that you move it to. Generally, the default would have an increase in sensitivity on the first half of the throttle, because you need to cover 0-85% of throttle in the cockpit to bring it from IDLE to the CLB detent. While the TCA quadrant can only cover this within 20% of range for each detent. That’s why by default the sensitivity is increased so that it can cover 85% of thrust using only 20% of movement in the quadrant. Plus it’s also designed to have reverse thrust using the same axis. Meaning the IDLE is not actually at 0% and the reverse is at negative value. Instead, the IDLE is actually at 20% thrust, while the full reverse is between 0%-20%. That’s why these are translated differently to different aircrafts. And it’s important to adjust the sensitivity curve accordingly.

When you are flying a different aircraft, let’s say a prop, or even the FBW A32NX aircraft. You need to duplicate into a separate profile specific to make it work for them. For these, you might need to adjust the sensitivity to have everything set to 0% except for the reactivity which needs to be 100%. This setting will make your throttle control to be fully linear. Meaning a 20% of change in your quadrant translates to 20% of throttle movement in the Sim. Depending on the aircrafts you’re flying, you might need to adjust different sensitivity curve.

1 Like

Thanks, I have this issue with all the aircraft, I’ve reset the profile and reinstalled the driver but the same issue still there, the problem is the sim is not registering any of my inputs

So if you open the Control setting, you don’t see the hardware being detected at all? No bindings on the default profile? You should be able to move your throttle while opening the control page, and the throttle axis bar should move with it too.

No, it’s been detected and shows a picture of the throttle quadrant, but the issue is it’s not regestering some inputs sometimes

Hmm… strange… so if you press each and every button on the Input search box in the control options, they don’t react at all? And if you move the throttle lever, the throttle axis box doesn’t move as well?

it’s only the thrust lever axis sometimes it doesn’t detect the input so I have to repeat it multiple times

Does it work smoothly in the sensitivity settings menu?
Just a guess, but if your CPU is completely utilized, the PC can drop inputs,
maybe also check that?
If that were the case though, I would expect more problems that would not be limited to the thrust lever axis.

Also make sure that if using the FBW A32nx, you calibrate your throttle/detent positions in the EFB tablet.

yes, it works without issues in the menu, the PC generally work fine, I’ve never had this issue before it only occurs with my tca throttle

the issue unfortunately affect all aircraft including the A32nx

Can you post a screenshot of your axis setup? So I can see what function/s your throttle axes are mapped to?

Also. Tests in other games are valid but DIView is a handy little software that you can use to check functionality.

You can find it here.


(Bottom line, your throttle and PC are almost certainly fine but the function mapping in FS2020 is a bit…odd.)

Tried DIView, everything works fine, you can have a look at my settings here,

I have had this exact same problem. I also have lag with my rudder pedals as well as the TCA Throttle Quadrant. Hopefully it is fixed in Sim Update 6. Thank you for posting.