Missing option in Material Inspector

Hello, I wanted to add a custom texture to my project but I am stumped after creating the MaterialLib I wanted to add the texture but in the Material Inspector there is no ‘Surface type’ option, which should exist according to the SDK documentation. I am not sure if this is a bug or I am doing something wrong which prohibits me from getting the option. Any ideas?

You might need to assign the material to an apron, and then you may get the Surface Type option?

Also, you can edit the .material descriptor in your materials folder. It’s a text document similar to XML:

<Material Version="1.3.0" Name="red_asphalt" Guid="{8C5C8770-F0FD-4954-9526-9C2A2F2A7296}" SurfaceType="ASPHALT" Type="CODE_DIFFUSE" Metal="0.000000" Rough="0.000000" Opacity="1.000000" BlendMode="Transparent">
		<Texture FileName="Asphalt01_Albedo.png" Binding="MTL_BITMAP_DECAL0"/>
		<Texture FileName="Asphalt01_COMP.png" Binding="MTL_BITMAP_NORMAL_ROUGH_METAL"/>
		<Diffuse Red="1.000000" Green="1.000000" Blue="1.000000"/>
		<Emissive Red="0.000000" Green="0.000000" Blue="0.000000"/>
		<UVOffset U="0.000000" V="0.000000"/>
		<UVScale U="1.000000" V="1.000000"/>
			<Parameter X="0.020000" Y="0.600000" Z="0.000000" W="1.000000"/>
			<Parameter X="0.000000" Y="0.000000" Z="0.000000" W="0.000000"/>
			<Parameter X="0.000000" Y="0.000000" Z="0.000000" W="0.000000"/>
1 Like

Yeah I know about the XML but still wanted to track down to reason for that problem. Got some help on the sdk forum though Missing option in material inspector, can't select surface type - MSFS DevSupport Thanks for the reply anyway!