Missing some planes

Hey Guys,
I hope somebody can help me out. A few days ago i downloaded the A330-300 (from project Mega Pack). It worked well, but when is started the game again it kept checking for updates. I did found out that it could be a false addon or something. I decided to delete everything and download MSFS again. Now it works fine, but i’m missing some aircraft. The DV20, Cessna 172 Skyhawk, 787-10 Dreamliner. Sr22. Virus SW 121 and the Shock Ultra are not in the game anymore. When i check my contect manager i can see the livery files of those aircraft but not the aircraft itself. Same for the local files on my PC. Does anybody know what i can do to get those planes back?

Hi! something similar happend to me. From the content manager, i uninstalled the liveries autoinstalled after updates, and when i was going to create a new flight, some planes had dissapeared from the aircraft selector menu. You only need to redownload the planes again from the Content Manager (if you order it by size you will find then easily).

Cheers :slight_smile:

I have the same problem. Even the planes that are missing are the same (except the 172 skyhawk)! My thread
And the planes are nowhere to be found in the content manager!

I have a hypothesis of what the problem might be as I had a similar problem initially. For some reason I ended up having two different Microsoft accounts. I bought MSFS on one account, but in the beginning the Microsoft app store thingy forced me to log in with my other account. What I got when starting MSFS was the non-premium selection of aircraft.

In my case the fix was to log out of my second account in-game, and log into my first account instead.

You might want to check if the same thing happened to you! Other than that my theory is that it could still be related, i.e. you own a premium copy of the game but for some reason MSFS thinks that you don’t.

Go to the Content Manager and check the Not Installed list. You should find them there available to install.

that’s nice but it happens everytime I start the game. I have to download all over again everytime…