Missing texture and distorted texture

Hey, I’m building some landmarks for my local city.

I imported the watertower and have some issues with the textures:

As you can see some of the windows are missing.
All missing windows are the same texture. The ones you can see are a different texture.
The strange things is, there is one window still showing up on the staircase tower.
The windows that do appear are scaled wrong (they have 3 horizontal bars, but should have only 1)
And also the concrete texture above the top windows is distorted. It should look the same as the rest of the concrete.

Any clues?
All textures are a power of 2.
I have another question about this: can a texture for example be 512 x 1024, or does it have to be square?

The error log says x skipped, x done and 0 failed. (x is a number obviously)
I do get a bunch of errors saying ‘PackageBuilder | Couldn’t find asset configuration during partial build for file D:\Documents\MyFSProjects\Belgium Oost-Vlaanderen Aalst\PACKAGES\BELGIUM-OOST-VLAANDEREN-AALST\SCENERY\GLOBAL\SCENERY\TEXTURE\WATERTORENCONCRETEMAIN.PNG.DDS.JSON’ for all textures.

I’m using SketchUp and ModelConverterX. The base textures are a power of two, although rescaled to fit the model; I then rescale the images to become a power of 2 in MCX. But this doesn’t seem to be a problem for 9/10 textures in the model.

I am experiencing the same thing using Sketchup and MCX or Blender. The model looks fine when in either but within the game some of the textures are distorted. Did you perhaps stretch any of your textures in Sketchup?

Yes I did. I don’t see how you can properly texture without stretching?
I actually did a lot of texture stretching, but I don’t think I stretched the distorted texture.

At first I thought it was somehow related to stretching of textures but now I don’t believe that. I created a test object with 10’ steps so that I had to stretch the texture vertically more each step. As you can see the texture did not distort. I have created about 100 models so far and placed them in FS2020 and only a handful are doing this. I am going to open a ticket on Zendesk and send them some screenshots.

The thing I see that is common between your and mine distorted texture is that they have a gap in the middle. In your case for the window or grate, and in my case the windows.

Perhaps this is the cause? Could somebody confirm?

edit: however, the other textures with a gap in my model don’t have this issue.

I will create some windows on that test object and see.

1 Like

I added a rectangle to each face and textured it with a door. It doesn’t seem to distort. This evening I will try recessing the door a bit so that it is not flush with the face and see what that does.

Well I added a few windows. On the first window I counter sunk it about 1 inch. The second window is extruded about 1 inch. I even added an overhang on step #2 but I can’t get it to skew the textures.

I was wondering if you received a reply yet, or if it is just ‘solved’ on the Zendesk?

No reply yet and I don’t think I will get one. We will probably just notice that it is fixed in one of the upcoming updates.

1 Like

I did some more research on the problem.

It is definitely related to complex surfaces.
Previously the white antenna was a ‘group’ so it didn’t interact with the other surface. The distortion followed the red line.
Now I exploded that group which made the surface complexer. And now it distorts to this contact place.

At this point I would even be happy if someone could confirm they can create models for MSFS with SketchUp without any issue. :confused:

I was having something similar to this.

Solved my issue. Apparently I didn’t notice that my object detail slider was changed. Set it back to 95 and got rid of my aircraft distortion.

Ooh, I’m hoping to have the same issue then. Where is this slider? in SketchUp, MCX or MSFS?

Msfs options under graphics

Unfortunately this does not seem to be my issue either. My object LOD is at 135.

Dang I’m sorry

1 Like