Missing weather selection in flight

I select my flight, lay out the flight plan, weather, airports(s) etc. I get into the flight I open the on screen weather to change something and its not there. I scroll over to the left to the settings menu, scroll down to the weather to enable it, but its greyed out no matter what I do and how I have things set. Its always greyed out. No mods at all.

It was fine prior to the patch.

Anyone have any ideas?

Are you playing multiplayer in a group? Maybe, the last group is already set. If so, only the host of the group can change the weather settings…

Nope solo, no AI no Live players enabled. It worked until the update then just disappeared.

Go into the settings icon on the top bar in the sim… see if the weather got turned off, you may be able to turn it back on. This is while IN the sim

LOL sorry been there done that still no fix. Like I said I dont usually even use it but I wanted to change the time of day and found it like this. Also its greyed out in the settings on the top bar, everything else I can turn off or on, except for weather that is greyed out entirely.

Same here, sad

Weather only works when You run flightsim as adminstrator. Try this…You can permanently change the settings in compatability settings…

Didnt used to be that way, this just started happening after the patch.


It’s exactly the same thing that happens to me. It does not allow me to move anything related to the weather selection nor to move the time

and it no longer appears in the top menu or allows me to enable it

Yeah Ive tried everything I can think of and still havent fixed it. Was looking to see if there was a key bind for weather menu, if there is I havent found it yet.

This si the answer from the MSFS suportarla Team …”Thanks for contacting Microsoft Flight Simulator Support today. In the multiplayer section of the weather menu (your second screenshot), choose the middle square “all players (todos los)”. This should change the weather box from grey to usable.”, thats works for me…

1 Like

Going to go try this now thanks

This worked except I had to go turn multiplayer on in the data menu to do it. Didnt use to be this way, and thanks for the fix.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.