Mixed reality error 1-4 is doing my head in

I have used my Reverb G2 for two months but now have the error 1-4 each time I try to use the headset.
I have updated Nvidia (gtx1080) driver
WMR reinstalled, updated Windows etc etc
I’ve had a new V2 cable sent by HP but still no joy. HP has out a new headset and we’ve updated the firmware.
I’ve spent days trying to find a fix.
Is it possible that my GPU could be faulty or could it be an issue with the registry.
Help please guy’s.

Hey @MGT086027 ,
if the HP Reverb G2 doesn’t start up in Windows Mixed Reality, then press long on the button of the V2 cable until the white light switches OFF. Wait some seconds and the click the button again.
If this doesn’t work then take another USB-Port or put in the HDMI-cable in another slot.

I don’t know if it helps you, but I hope so.

Best wishes, Benni :slight_smile:

I have tried that method and tried in different USB ports and an external hub. I have tried the display cable in different ports.

Finally resolved the issue by having to reinstall Windows 11. I cannot believe how many days I have spent trying to resolve what should have been a quick fix.

Windows 11 servicing stack update - 22000.469 has been deployed, may resolve some WMR install errors associated the Win11.

This update makes quality improvements to the servicing stack, which is the component that installs Windows updates. Servicing stack updates (SSU) ensure that you have a robust and reliable servicing stack so that your devices can receive and install Microsoft updates. Key changes include:

  • Addresses multiple Features on Demand package failures that you typically encounter when you attempt to set up or install Windows Mixed Reality.

Is this service stack available as a standalone update

This was a automatic update that appeared today for my Win11 system.

January 25, 2022—KB5008353 (OS Build 22000.469) Preview Windows 11

My OS build is now 22000.469 Windows Feature Experience Pack 1000.22000.469.0

Finally got WMR working and MSFS, unfortunately I had to reinstall Windows, create a new user account in Windows and reinstall MSFS just because of a simple error 1-4 when starting up the Reverb headset.

I had the same problem twice now.
First about 6 months ago my v1 cable died (G2 screen black and error code 1-4). HP sent me a v2 replacement cable and that solved the problem.

Some days ago my G2 stopped working again with the same problems as above. It was working fine one day before. I have tried everything what the forums say and even tried a brand new v2 cable that I bought as a spare. Still no joy.

Than as a last resort I made a widows restore to a point about a month ago. I have freshly installed windows 10 pro about a month ago so that point was just after the windows was installed and updated.

The restore was successful and when starting Microsoft app store I noticed 3 errors regarding Microsoft Visual C++ Redistributable. I cleared them/canceled them and stared Mixed reality portal and the G2 is now working as before!!!

So i guess some background updates in windows corrupted the WMR platform which is really bad…also because the user doesn’t notice anything. I thought the cable was again the problem but this time it was windows.

I will have to carefully do the next windows updates and check if they brake WMR again.

Hope this helps people because the Reverb G2 is great and makes MSFS2020 worth while. Going through this frustrations second time now I know how annoying and disappointing it can be.


Did anyone discovered what is the update that is messing with hp reverb g2 ?
thanks guys

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.