Mixture control moves on it own back to idle cut off - Honeycomb Bravo

Installed latest version of FSim with Honeycomb Bravo Throttle Control on Windows 10 PC.
Mixture control properly moves up and down. However, after moving it forward, it starts slowly sliding back to idle cut off position and engine stops.
Same happens regardless of auto mixture turned off or on.
Happens on all piston engines with mixture control.
Attempting to hold mixture control at full rich does not help.
Mixture control moves smoothly up and down when validating in Bravo Settings menu.
Reassigning mixture control to a different position on Honeycomb Bravo does not fix.
Any idea why mixture control keeps sliding back on its own to idle cut off?
Thank you.

Hi @LuciusF,
I just setup mine a few days ago. At first I only setup 3 levers (for single engine) and had the same issue as you. Then I put on all levers as if twin engines.

So for single engine, I move 2 levers together. Twins, each works independently. This required no changes to the Honeycomb Bravo default profile in MSFS. Also I can fly single or twins without removing levers or changing profiles in MSFS.

Did you install the software from Honeycomb? It will enable the lights on the Bravo and you’ll see “Afc_bridge” in the Content Manager. It will indicate that needs downloaded. You don’t need to download it.

No issues like that with mine, works as planned.

For fun, turn off all assists and set “true to life” just to rule it out.

This is the guide I used to setup my 5 profiles

1 Like

Are you sure your axis is not reversed?