Mouse is extremely laggy and I can barely click on anything after loading flight

Since Sim update 7, my mouse is to laggy and I have to click like 5 times for it to obey the command. The mouse works fine setting up the flight and using the menu but after I load the flight all the sudden it laggs horribly. I have to click “fly now” like 5 times for it to finally work and after that I have the same problems with using the mouse to change views, load the ATC menu or pause it and change settings! Please help, it makes it impossible to fly at all!

In msfs options there is a slider to adjust mouse sensitivity. Did you have a look at that?
Else, have a look at the mouse sensitivity settings in windows 10 (I am guessing you run that).

Whenever a key is pressed or a mouse moved, the hardware send a signal to Windows to immediately process the key press or mouse movement before doing anything else. There cannot be any delay. If there is a delay, then something very big is preventing Windows from switching over to process the key press or mouse movement.

I don’t know your system or exactly what you are doing so I do not know exactly the cause of your problem. Since everything seems to work fine until you press “Fly!”, starting a flight is triggering something. I have seen situations like landing where the FPS drops significantly. For some unknown reason (to me), at that time MSFS is downloading a massive amount of files, hundreds of megabytes, and then processes them. Windows has to accept all thes files for MSFS. It can’t say “no” because someone is landing an aircraft.

At the start of every flight, MSFS has to collect all the scenery, textures, and object files it needs for your takeoff. There might be so many files that MSFS needs that it results in mouse lag. Every MSFS update changes how files are processed which is why users notice “a change” after an update.

What I do when I see FPS drop or lots of stutters is take a few minutes break. I give MSFS time to download and process everything it needs. When I return, performance is back to normal. This is my attempt at a workaround before this problem is fixed.

Yes, I tried changing that. It doesn’t do anything. The mouse just doesn’t want to respond! It has nothing to do with the mouse sensitivity!

I’m using Windows 10. Okay, how long should I wait? The mouse just doesn’t want to respond to my commands and it’s getting really frustrating as I haven’t been able to fix this problem since updating the sim! I just want it to work normally like it did before I updated. There has to be a way to fix it!!!

1 Like

Start by disconnecting all other peripherals and see if that helps. If it does, re-connect one by one until you find the one causing these issues.

Otherwise, it might be a key binding that got messed up with the update. Try re-setting all control profiles to default.

After SU5, my old wired xbox controller caused the same issue as you described here, but I was not able to fix it. It works fine in other games, and it worked just fine pre-SU5 in msfs.

Hope this helps.

I share your frustration! There is nothing we can do to fix it because it is just poor design, just try different workarounds. Hopefully this will be fixed in the next update.

Try taking a five minute break…

1 Like

Check and see if this is similar to your problem. There are some workarounds noted.

That was another problem I did have after the update, but I just reset the mouse to default and it worked. However setting the mouse to default does not fix the problem of my mouse lag!

I have a similar problem in VR. Mouse clicks work oke but getting the mouse pointer to where I want to click is extremely laggy. Very frustrating indeed. I’ll go and try the suggestions I read here, hope that helps.

Found the solution. I had to increase the deadzone on my Saitek yoke (aileron) a little to eliminate some spiking in the center. With that the mouse lag was gone.

I have the same issue with the beta update. Changed my driver to the newest nvidia driver (.29) solved it. But then i lost 10 FPS . So i roll back to .09. And also got the issue again…
With MSFS running and then change (with alt tab) my screen to another window and go back to the sim, the issue was gone (but not always). I also noticed when i open a window on my second screen the issue was gone (also not always).
Sometimes a MSFS restart does also helps (again not always).
I think some-how the MSFS screen blocked the input interrupt but gives in return very high FPS.
Strange but for me the highest FPS are a must (VR user) so i have to deal with it (for now).
If FPS are for you not important, change to the newest driver 497.29. (Or are you on AMD?)
Perhaps it is a issue with geforce experience overlay (i saw recent that was updated also…). But i have still to try that.

edit: 31 jan 2022. This issue is back again with the world update 7 this evening.
It was gone with the hotfix last december. :thinking:

I just have the Logitech flight stick! Do you know what I could do to solve the problem with it? Also even when I haven’t had it plugged in, I still got the mouse lag so I’m really hoping I can fix the problem the same way you did! I’m on vacation now, so I won’t be able to test it out until the 31st!

If the mouse lags with the Logitech unplugged it doesn’t seem the cause. You could check other USB peripherals for spikes (wobbling) on some axis. But best to wait for the next update, there’s other issues still with the mouse.

I would prefer not to wait until the next update since I Googled when it’s gonna be and it says it’s not gonna be until late February! Do you know anything else I can do? How do I update my newest nvidia driver?

Found solution: Turned off Photogrammetry and everything went back to normal! Also realized it was only lagging while I was on the ground. Once I took off everything was normal and then once I landed it would be laggy again. As soon as I turned off Photogrammetry the FPS were normal when I loaded my flight at the gate!

Since the latest update, my mouse has become very jerky and very slow to respond to mouse clicks. It makes panning very difficult and it often takes 3 - 4 mouse clicks to activate buttons and switches. It makes it difficult to fly.