Unable to pan world map (using a mouse) since SU7

Are you on Steam or Microsoft Store version?
MS

Are you using Developer Mode or made changes in it?
No

Brief description of the issue:
World map can not be panned with the mouse any more.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

Mod Edit: A workaround is posted in the release notes:

Random thought and may be totally unrelated but have you checked your key assignments on your mouse?

Same here. Any suggestion what I could check?

1 Like

same here. couldnt see any keybinds that could be related

1 Like

“Yes they’re aware of this bug. They stated they will fix things asap post launch since there wasn’t a true long duration beta testing this time around”

I’ve got this response here Discussion + Poll: GOTY (1.21.13.0) - #161 by crazymaherm

2 Likes

FIX - reset your mouse control to the default profile
controls → preset manager → mouse → reset to defaults

28 Likes

edit: @Samueleonard 's tip do the job, thanks! :slight_smile:

1 Like

You can use numpad 4 6 8 and 2 to move the globe.

5 Likes

@saschpe please indicate if @Samueleonard post fixed your problem. Thanks.

Same issue on Xbox, at least the controller works.

Toggle thrust reverse is now jacked up too on my T Flight Hotas

I ran into this issue too, reverting to defaults fixes the issue. I couldn’t find any specific binding that was missing but it seemed to have worked.

Have the same bug. Right and left mouse buttons do nothing. I found that you can move around if you scroll back, place cursor near airport you want the scroll back in. I know it is stupid, but it works until they fix the thing that wasn’t broken before the “update”.

Did you try resetting your mouse profile to default?

I just had to go through all of my settings as everything was turned on for some reason. My mouse was making the map freak out when I tried moving the map and zooming in and out. Putting it back to default (which is where it was in the beginning) fixed it though. These updates leave me scratching my head sometimes.

1 Like

That did not work for me

1 Like

no deference

Finally, I got it to work as you said. Gees.

1 Like

Nice :slight_smile: Thank you so much!

yeah that worked for me also default mouse setting although cant find the setting in default which makes this work
thanks for this