Mouse not operating controls in any aircraft

Hello, I have an odd problem in which I cannot change the status of any button or control in any aircraft with my mouse. The cursor changes shape correctly, but clicking/scrolling with the mouse wheel does nothing. Right-clicking does work to move around the cockpit.

  • I’ve toggled the value of “Cockpit Interaction mode” to “Legacy”.
  • I’ve reset the values of everything on Keyboard and Mouse to “Default”.
  • I’ve disconnected the rudder pedals and Hota.
  • I’ve uninstalled and reinstalled the simulator (that was fun).

The mouse still doesn’t want to be able to control anything in the aircraft. Help!

Thanks.

Do you have “home cockpit mode” enabled? It’s under the camera settings. If so then disable it.

Thanks for the advice, but that’s not it. “Home cockpit mode” was disabled.

Thinking about the basics, you seem to have checked the main factors. The only other factor I can think of is the sim window should be frontmost/active. Here’s a couple thoughts on that.

  1. Are you running in fullscreen or windowed mode. Maybe try the other.
  2. Do you have more than 1 monitor? Maybe disable the others?
  3. Is there some other application or background process that could be taking focus?
  4. Do you have a logitech mouse using logi options? Is there a special mouse profile for the sim in your mouse software?

I doubt it’s any of those things but you never know.

I’ve tried what you suggested and more, even uninstalled specific mouse drivers, no luck.

OK. Last try. :wink:

Here’s a link to the zendesk with troubleshooting help. Maybe something in there can help you.

I was thinking maybe you have a software conflict with the game and found this. Maybe you have a conflict with another app so take a look at the section called " CONFLICTS CAUSED BY AUDIO DRIVERS & OTHER APPLICATIONS".

That’s all I can think of. Good luck.