Mouse wheel bug with new mouse controls

Sorry, mate, but first of all - it does not make sense, because it’s still a bug. And no, it’s not designed only for controllers. Second - using LOCK interaction is very nice and useful in many situation. For example in legacy mode you cannot normally turn knobs with mouse in turbulence, because many times you will miss the knob, which will result in zoom in / zoom out.

Holding the left mouse button down while trying to use the scroll wheel is stupid awkward. It should have been the right mouse button.

that’s why I have my inputs for those ‘commands’ either on the yoke or keyboard

That’s why I set my zoom mode to Focus instead of scroll wheel, if I miss the knob it doesn’t do anything. If I want to zoom, I just right click on a spot that I want to zoom in.

Hm. How do i do that? Is there some setting for this? Want to check it mysefl.

In your General Options under Camera, you should see Zoom Function that you can switch between Manual or Focus.

Manual = using scroll wheel to zoom in and out.
Focus = using right click to zoom in and out.

I choose focus to avoid accidental zoom due to my cursor missing the knob.

All you need to do is go to menu change to legacy view for cockpit interaction and it will be back to how it was before update.

Yeah. This works, but not my prefered type of contorls.

Why? I like how new cockpit interaction works. But there is a bug and they probably need to fix it.

1 Like

It’s very subjective, some like it some don’t. I would like it if I can disable the blue glow… That’s my biggest immersion breaker.

I think they will add this option in future. Or maybe someone will disable it with some mod.
And yeah, ofc it’s subjective. But if we have both options - they must be implemented nicely.

Not a bug psb

Hi, I hope I’m not intruding into this thread, but it’s the closest I found to my problem.

I done the update yesterday, Saturday, but now the cockpit knobs switches etc, don’t work. When I put the mouse say on the Taxi Lights switch or any knob, it just glows blue and a widow pops out with the name of the knob or switch and under it says “Press ? to Interact” but nothing happens. Please see pic below as an example.

Tried moving the mouse left, right, up down etc. nothing works! tried both the B787 and the A320’ Any help please would be appreciated. Thanks in advance

Sorry Guys, but after writing the post I went to Options and changed My Mouse Profile to Default, just to try if it was the problem and it was. So it’s all OK and back to normal now. Thanks to all that was going to help, but this may serve as a helpful post to others that may stumble to this same problem. Thanks anyway.

You might also need to go to your General Options → Accessibility → Cockpit Interactions. And change this to Legacy.

Thanks for the info Neo4316. I’ll give that a try tomorrow. Would that make any other differences besides being able to turn knobs and operate switches? That glowing blue and windows opening every time you move the mouse on knobs, switches etc is really bothering me too!

Legacy cockpit interaction will remove the blue glow. Legacy setting is optimised for mouse users and will bring the interaction back to before the SU5.

I did change it to Legacy and the Blue glow is gone. While I was there, I also switched off the Instrument Name Tooltips, as they were annoying me! Also, I went back to the Control Options and changed the Mouse back to My Profile, as it was initially. This tells me that all I had to do is to change back to Legacy in the first place but I didn’t know how to get there! So thanks to you Neo, it seems that I’m now back to Normal! I hope this could be of some help to others too. Thanks once again.

No problem. I’ve been saying the same thing to different posts everyday now. Glad it works for you.

all - I cannot get mouse to move some buttons and switches for instance; the landing lights on 747, the beacon on 747, Neither work, this has been reoccoring issues since release. If cannot make basic systems work, “it is NOT as real as it gets” and in actual violation of FAA/Other agencies flight rules. I am going to delete mouse profile completely, and if I have to input again by hand, at least it should then work. What PIA.

Hi, does someone now why my mouse appear but the clicks doesn’t work? I’m on an Xbox series S