MS Sidewinder Force Feedback 2 not working

My MS Sidewinder Force Feedback 2 isn’t working.
Admittedly it’s an old piece of kit, but it’s still a great joystick, and it’s recognised properly in Win 10 and works great in Xplane.

In FS 2020 the joystick tab shows not bindings of any functions. It flashes up for half a second and then the screen is empty. I have added some functions manually, but it’s always on or off all the way, ie during take off I carefully pull back the joystick and boom it goes up all the way, the same turns and the throttle. There a no values in between.

Anyone has any work around for that problem?

3 Likes

you need to assign axis to the left gray box.
In case you don’t find all axis, remove the “essential” filter.

Just to add to DP292 here is what things should look like if correctly assigned.
I also needed to add dead zones to my ancient but working Microsoft Precision Sidewinder.
image
Hope this helps.

I think also you can change the sensetivity of each axis, its the blue box in the assign keys page, i have a microsoft sidewinder precision 2 joystick and im having trouble with it, i am able to bind the slider for the throttle but when i get in game it wont work properly.might be just to old now, anyway i hope you get it sorted.

You should be able to get it working just fine. There are several threads from the alpha beta times you can search for that will help within these forums. Adding in Dead zones has changed to the blue button you describe and is not ‘F10’ anymore.

ive tried binding it to slider axis X, wont work, then i tried slider axis x+ and x -, that sort of worked, only the top portion or the bottom portion of the slider is working, so i cant go from slider up, full throttle, to slider down, no throttle, both start half way on the slider if you get what im trying to say, anyway its very annoying, cant be precise at all, but i will look at the forums thanks

I think you are talking throttle settings. Here are mine. I have an original precision not V.2 but I think it will hopefully work. I have mapped 2 throttles for flying the Airbus.

1 Like

Ah i see, its the only one i havent tried yet, mapping it to THROTTLE 1 AXIS, i have been trying INCREASE and DECREASE THROTTLE options, i will give this a try tonight and let you know if it works this way, thanks

YES IT WORKED ,thanks for the help

1 Like

Happy to help - not exactly intuitive is it? :slight_smile:

no,not really

can i just ask one more thing, whats happening with the multiplayer, i was flying for like 2 hours earlier and saw nobody online, im on the european server and flew over uk then usa florida area and saw not one person, are there problems with online play or do you have to be friends with somebody, i thought it would be like fsx where you could join a server and see people

I have been flying with a friend and it works great. Make sure your Multiplayer is not set to off (Go to flight conditions on flight planning page to check this.) We usually use the All players setting. You have to be fairly close to others to ‘see’ them. Turn on 'Show Traffic Nameplates in general - traffic settings to make people more easy to spot. Hope this helps.

Anyone has a good setup to share? wonder if we can share setup files…

1 Like

I was able to setup mine to work decently well by mapping all the buttons. How can one find which file to share?

1 Like

Thank you, guys.
With Profsc410’s settings it’s working perfectly now, so I’m super happy!

No idea yet, will look into that, I’m having trouble with the throttle slider, it only detects it as digital, up and down so if I set to increase and decrease the throttle, it goes either max or none. Any tips?

Have a look at post 6 above. Are you choosing Throttle Axis to use with the slider?

1 Like

Ok, so you mapped 2 throttle knobs into one, can probably do all 4 into one. Will try tonight, Thank you

Perfectamundo, finally, thank you. Now if only I can get the FFB to work…