MSFS 2020 ATC keeps overriding vPILOT

My default ATC in MSFS 2020 keeps overriding vPILOT frequencies. I have tried going to the menu at the top of the screen and turning ATC off but that doesn’t work.

How can I use vPILOT for VATSIM with MSFS 2020?

Hi Lion,

yes, Vatsim works for me.
Turn off ATC before loading your flight (not when the flight is loaded)
Also start vpilot as administrator.

Hope this helps.

As @Skyvertical already said, make sure to start vPilot, when you are loaded into the flight,not before.

I’ll give this a try next time. Thanks for the tip!

I would suggest disabling your copilot from handling comms. Charlie(your copilot) would always response to MFS ATC when enabled.

Have a blessed day

co-pilot off, ATC off

As soon as I enter the flap configuration for take-off, I get the request for pushback to the AI ground controller when no request is made and from there on, I won’t be able to contact VATSIM because the frequency keeps getting overridden.

All this is prior to vPILOT even being started up (with or without starting as Administrator).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.