MSFS 2020 Crash in VR - HP Reverb G2

Hi all,

This is my first post on the VR forum. I used to be involved in VR when the first Oculus rift was crowd funded then lost interests until MSFS 2020. I recently bought an HP Reverb G2 and noticed a few crashes that make the G2 not really usable. When it works, usually it is sort of smooth but the big drawback is that it will crash while in VR mode. First time I tried the VR I selected the activities/bush trips. I managed to fly 1 hour then it crashed. Symptoms were: video frozen in the helmet (and desktop if I liftd my helmet), then blackout with sound still on in the helmet. Eventually after a few minutes, MSFS will crash then it will return to the desktop and I’ll get an AMD driver message about a driver time out. When flying, it was smooth and I did not tinker a lot with the VR settings (in fact I did not realise that under “graphics” you could switch to VR so the graphics settings were at their defaults values). Following that I started to tweak the settings in graphic to make sure that they were not stressing my video card (5600 XT), installed openxr dev tools, found some recommendations about adding “tdrdelay” in one of the windows registry to give some extra time to the drivers but all that contributed to have more stuttering in VR. Also disabled “Game mode” in windows, check that Hardware GPU acceleration in windows was disabled (did not have this option) and also that the MSFS executable had its “disabled full screen optimisation” as per one of the youtube video).
So in the end I removed the openxr dev tool but left game mode off, the tdrdelay and the graphic settings as they were. No more stuttering in VR but still crashing. Except that this time I don’t have the AMD driver time out message. So not sure if it is the tdrdelay that is fixing this issue but the crash is still there and I don’t know what it is since there is no message. And the crashes are getting more and more frequent. Now not 5 minutes within a flight it will crash. One crash was so bad that it crashes the whole system. But the big BUT is that i can fly the same flight plan not in VR and I have no issue. I could resume the bush trip or the flight that crashed within 5 minutes, fly for another hour in non VR mode and everything was fine. I am at the point where I don’t know where to look so hopefully someone can help. I could remove the tdrdelay in the registry and see if next time it crashes the AMD driver time out message reappear just that I know at least this tweak is fixing one issue.
Note also that the video card is not overclocked and I am using the latest AMD drivers (updated yesterday) and windows is up to date as well.
My config is:
Gigabyte Z490 Vision D motherboard
i9 10700k stock speed
Gigabyte 5600 XT 6GB stock speed
64 GB 3600Mhz (stock speed)
HP Reverb G2 connected to video card display port and usb-c at the back of motherboard

Thanks a lot

3 Likes

Same issue here… there seems to be a bottleneck somewhere that can’t be resolved. I live in hope that someone finds a fix! Cheers buddy

1 Like

Exactly the same issue. Z490 Vision D + 10850K + 6800XT. So my best guess is either the SIM bug or AMD driver issue.
I’ve tried TdrDelay as well, but all it does is to make Windows wait a little longer before shutting down the app to protect the hard crash. Not a solution. Keep filing bug report with AMD as well as MS/Asobo so that they will take this seriously. I can hardly finish a flight without crashing these days. It all started happening with the latest sim update. Never had one single crash until this last update.

1 Like

Check if your USB port are not set to go in sleep mode after few minutes

Also add IdleTimerDuration=10800000 and PreallocateVirtualMonitors=0 in your registry

Q 3.10 in this document

And until an official fix, run FS in admin mode

1 Like

I have the exact same problem. I have the HP Reverb G2 connected to USB Type C on the motherboard (or does not work) and on my DP on my Sapphire Nitro+ RX 5700 XT with latest drivers 21.2.1 but same with previous AMD Radeon driver. I have a AMD Ryzen 9 5900X on a Aorus Master X570 with latest Windows 10 20H2. Runs ok but crashed to desktop with AMD report.

2 Likes

I’m also having the same problem. Sometimes I can fly for 20 minutes before FS shuts down. Other times it happens within 5 minutes. It’s very frustrating. Running AMD Ryzen 9 5950x CPU with AMD Sapphire Radion RX 6800XT.

It can be of help though (unrelated to FS2020):
PSA: Solution to HDD and NVidia causing Win10 System Halt with Black Screen

I’m having the exact same issue with my 5700xt and the HP Reverb g2. No problems with MSFS 2020 in non-VR mode. But 5-10 min in VR and the game crashes hard with a driver timeout error.

Same Here.
My setup:
HMD ODYSSEY+
AMD 6800XT
RYZEN 3600
2x8GB Mushkin DDR4

There’s obviously a weakness in the driver that MSFS VR exposes because this is the only thing that causes me crashes on my Sapphire 6800XT.

Furmark runs flawlessly with comfortable temps even with the fan profile only running up to 40-45%, Alyx runs flawlessly, as does Elite Dangerous on VR Ultra. Not a single other program, VR or otherwise has caused this problem.

Currently running 21.2.2 drivers but changing between the few options available for the 6800XT makes no difference for me.

I’ve been running into this a lot.

The other day I uncovered a thread about FS2020 and random CTD’s. It suggested setting your Windows Pagefile settings to minimum of 1.5x your RAM size and the max of 3x your RAM size.

I did that and was able to fly a few hours yesterday without issue. Could just be random but I’m assuming this helped.

Instructions here; Adjust Page File in Windows 10 (How to Set the Right Size)

1 Like

There is a striking similarity in all of these CTDs. Majority of us are using AMD GPU. I have been wondering if this is really the AMD issue. I get driver timeout detected error with d3d11.dll as faulting module in the event viewer.

The problem is not just with VR. I’ve unplugged G2 and tried the 2d and the sim still crashes in the same manner.

I used to have those issues and were releated to overclocking, specially the graphic card. Since I left the OC to the default values it hasnt crashed. In case it helps-.

I ahve the same issue. Game Crashes to desktop sometimes after a few minutes of flying, sometimes it takes up to 45 Minutes.
My Setup:
Ryzen 9 5950x
AMD 6900XT
ASUS AORUS gaming
64GB Corsair
HP Reverb G2

Havn’t tried without VR yet but I’ve tried with a Oculus Rift S and didn’t have crashes there. (But Oculus has its own problems. White flashes and flickering).

1 Like

Try using the oculus v27 beta, it fixes the crashes and flickering in my experience.

1 Like

I’ve gone back and Forward a bit with the Beta but the HP has a uch better resolution and now it seems I can’t really go back. But thanks.

I did try a few things now from this thread. Not sure witch one helped now.

  • I’ve turned of the engery saving for all USB ports.
  • I’ve resised the pagefile to 1,5x -3.0x the RAM size <<edit: Looks like this did not have an impact.>>
  • I’ve started Flight Simutlator as an Administrator. <<edit: So I didn’t start MSFS as Admin and didn’t have any crashes>>

And did a flight for about one hour without any issues.

Lets see if I can narrow it down but it seems to have worked.

Edit: So in the End it looks like the Energy setting of the USB hubs was the reason for the crashes. Since I had the Option disabled I didn’t have any crashes.
I need ot be careful though. Every time I change a USB port I need to check this setting.

1 Like

Thanks for the information. I have disabled the USB Energy savings and will see if that fixes the problem I have been having the exact same issue as you with almost the identical hardware setup as you.

My Setup:
Ryzen 9 5950x
AMD Sapphire Nitro+ RX 6800XT
ASUS TUF gaming B550-PLUS
32GB Corsair
HP Reverb G2

I’m curious as to how your framerates are in MSFS with VR? What are your VR display settings and OpenXR settings if you don’t mind sharing? I’m also wondering if I should increase my ram to 64GB like you.

I’ll try to give some Settings and framerates but it really is a work in progress. Usually i change them back an forward depending on where I fly. Turn them up in Bush flying and down if I fly in big cities…

But I would say that 32GB is well enough 64GB will probably not change anything. I never get above 20 - 25GB of usage. And I run a lot in the background. I just bought the 64GB since I build a new system but right now it doesn’t pay of in MSFS.

I have the same issue as you. Ryzen 7 5800x, AMD 6800XT (21.2.2 drivers), ASUS X-570F, 32GB RAM, G2.
As I have plugged the G2 direct to my GPU, I have to check were to switch off the energy saving - but I am wondering, why not other VR games having issue when I play 1 or 2 hours. :thinking:

I will try to start MSFS not in Admin mode - maybe this will help - could be a good tipp!

Just tried again and had not crash flying about 1 hour.
Here are my settings. Flying in moderate populated areas I get between 36FPS and 42FPS

1 Like