Msfs 2020 won't launch

Dear fellow pilots,

When I started my MSFS this weekend, nothing happened. It won’t launch. No error message, nothing. Last time there was no problem at all.

Windows update, Xbox app update, log in again. Reinstall MSFS several times. Install via store, install via Xbox app. Nothing seems to help. I think I have tried all the suggestions on the internet. \

What is strange is that MSFS installs the 2 GB, but cannot start the MSFS.

I do see under programs that MSFS (standard) is installed and also digital proof of ownership. But in the windows store msfs is not visible and in the x box app it is visible, but is shown as not installed.

Does anyone have any ideas what else I can try before I have to reinstall Windows altogether?

Msfs standard / store / windows 10

Greetings Matthieu.

I moved this topic from Wishlist to the User Support Hub because it is a troubleshooting topic and not a new feature request.


I had the same issue this weekend. I went to the MS store, look for all applications to be updated and there was one that has been downloaded again. I don’t know how it was deleted or what happened, but after having re-installed it MSFS launched correctly. So my recommendation is to look again in your MS Store for any application that needs to be updated.

Thank you for your response. Checking for updates in the store was the first thing I did. were a number of apps that needed an update. but it didn’t help. MSFS is also not visible in the library at all.


Check if you have this one and when was the last update. In English should be Games Services (or something like that :slight_smile: ). This is the one that was missing and prevented MSFS to be launched without any error message as you mentioned.

Thanks again for the response.

I had also read about that gamingservice.

This is also up to date.

Just checked again to be sure.


In Services are you seeing Gaming Services running ?

Log out of Microsoft Store. Log out of Xbox game app. Then log back in to both in the same order. You are welcome.

FWIW, I had this issue too. Four hours of troubleshooting. After logging out, logging back in didn’t work, kept getting a password error message until I restarted my PC. It’s all FM (freaking magic) to me.

1 Like

I found doing the Norwegian Fish Dance - slapping two North Sea cod together over my PC while chanting the required verses - worked. But only once. Go figure.


I can’t start FS2020 either :grimacing:

Many thanks to everyone who tried their best to help me.

After many hours of trouble shooting. Searching the internet, reinstalling the simulator and related applications and almost being ready to throw my computer out the window, the solution was really very simple.

The time…

My computer was still on winter time and had not adjusted this automatically.

After I entered the correct time and date, everything works again.

Okay, I have to update 132 GB due to the new installation, but it works again.

Thanks again!

See you in the sky.



Well, I’m about to try the Norwegian fish Dance.

It all worked yesterday; today MSFS won’t launch. Restarted; logged out; logged in; restarted; rinse and repeat. Nothing works.

And if anyone suggests wiping the PC and reloading MSFS and everything else, I can tell you where those North Sea cod will be (politely) placed… And no, my computer is definitely on the right time. I think I will try again tomorrow.

Is it on the right day though? :stuck_out_tongue:
(Don’t kill me, trying to lighten the load!).

What does it do? Just closes from loading screen? Not get that far? Anything at all?

But to actually try and be useful and not annoying to you… just some things you could try:

  1. Check in Windows Event Viewer. Any errors at the time?

  2. Delete SceneryIndex (the contents of that folder) — inside here:

Microsoft Store/Xbox App:



C:\Users\YourUsername\AppData\Roaming\Microsoft Flight Simulator\SceneryIndexes

  1. Delete content.xml file in the root install folder.

  2. Check if Windows installed any updates (in update history) yesterday.

  3. Clear DX and NV Caches (all of them) — there is a guide here (scroll down):

1 Like

Hey @Baracus250 Thanks for the the things to look at - very much appreciated!

MSFS is just thinking a bit at start (a few seconds of the hour-glass) and then … nothing.

I seem to be having some connection issue with XBOX services. Who knows why - my internet is working just fine. Perhaps it’s left over from all the solar flares at the weekend :grinning:

I’m out of time tonight but will take a deeper look tomorrow. I’m not aware of any updates, but then they seem to be secret these days anyway. Something somewhere will probably reconnect and it will start working again without me ever knowing why. If I do find a specific cause - will post here.

Again - thanks for the ideas!

1 Like

Thanks. Pursuit of the ‘gaming services’ issue and updating in store solved the problem when it arose out of nowhere today.

1 Like

Many thanks! Seems the solution in my case was the stopped gaming services and an update that didn’t