MSFS always asks for Windows Firewall

Hi there, since I didnt find anything searching for it: When I start MSFS the win firewall pops up and asking for clearance. Every time, even if granted. On every startup.

Any idea what I can do here? I already “allowed” it in Windows Defender and all the stuff, but it keeps asking…

Thx

1 Like

Me too {10 characters}

Hi @Follhorst,
Is the Windows 10 account you are logged in as have Administrator rights?

You can also try running MSFS as Admin and when that firewall permission pops up, grant it.

Another reason this pops up is if your network connection is set to “Public” rather than “Private”.

All that you have suggested is already a given for a long time.
MSFS started asking about the firewall 3 days ago but nothing in my setup has changed.
Do you know why?
Thank You.

Windows did also when Asobo/Microsoft pushed (by mistake) the livery update. None since then.

Same here (10 chars)

Hi @FunkyHut,
Another thing that can cause this is “tunneling” (used by VPNs). If you have a VPN installed or have uninstalled one see if that tunneling it used got removed.

You can find this from Windows 10 Settings > Network & Internet > Ethernet > Change Adaptor Options (text link upper right of screen) and look for any “tunneling” protocols/adaptors.

MSFS does need access through the firewall as it opens and closes ports. The prompt you are getting is coming from Windows Firewall as it detects that MSFS is trying to open a needed port(s). The prompt is not coming from MSFS.

If your Windows 10 firewall continues to prompt this and you have check that you have Admin rights and your internet connection is not set to “Public” try running the Windows 10 troubleshooter to see if there’s any problem with the Windows 10 Firewall.

To note: Disabling the firewall is not a good idea as it will open your PC to attacks and manually opening ports in it is also not a good idea. I’m putting this out there as I’ve seen other posts on the forum doing this. Those that do this should have an external firewall handling those requests. Also, disabling the Windows 10 Firewall will cause the xbox multiplayer to not work.

Along with the troubleshooter, you can also run the System File Checker from the command prompt: sfc /scannow to see if it finds & corrects errors with Windows 10 system files.

No vpn.
Done everything else.
As I said this has just started to happen and I’ve not changed anything on pc.
I have a love hate relationship with this game. It’s a perfect window on the world when used together with PSX and WidePSX. But as a flight simulator it’s a toy to anyone seriously into flight simming.
And these constant glitches make it a pain to keep running and updating.
Thank you for your suggestions. Much appreciated but not any solutions.

Looks like its always starting from a different location, I have seen a couple of Driveletters here. C:, D:, H:, Z:\ always followed by a 0 when asking for firewall-passing.

Looks like a windows-app-problem to me, not a MSFS-only-related thing. No idea where it comes from though.

I have a few of these and always “cancel” as I am not granting access to something that is trying to install on a completely different drive to the one I have MSFS 2020 installed on and with an Unknown Publisher.
wtf
2020-11-26
2020-12-05

I even hesitated on joining this forum due the Unverified publisher.

1 Like

I also get the Windows 10 Defender Firewall window randomly, even though my anti-virus software is not defender, the strange thing is I set the .exe file to communicate on my own private home network and I uncheck public networks then when the message appears again, both check-boxes are checked…

Same issue here, started happening after one of the updates. Drive path seems to change randomly

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.