MSFS Application Error - memory could not be read

Got similar the other day in 1.24.5.0:

The instruction at 0x00007FF7BF8F1EE4 referenced memory at 0x00000000000054C. The memory could not be read.
Click on OK to terminate the program.

It cleared up after a restart of MSFS, if I remember correctly.
Configuration: Asus Tuf Gaming X570 Pro Wifi, 32GB Memory, AMD 5600x, nVidia GTX 750 TI 2GB (that’s right, below minimum recommended) but it runs nicely.

1 Like

Got this error message twice this week. Saw it for the first time ever. Not reproducable. No beta user here. Tested my RAM, changed virtual ram from windows managed to custom settings. Did not got the error on today’s 2 flights that were 1,5 and 3 hours.

Got this message today for the first time. Not a beta tester. Rebooted PC and restarted FS everything then OK.
I7 32GB RTX3080

Yeah … it’s a quite annoying to reboot the PC (and reload the FS2020) because of this bug.

I just started getting this last weekend flying from St Louis to Chicago in PMDG DC6. Restarted system and sim and attempted flight again. Got same error at about the same spot (about 30min north of STL). Restarted system and sim and changed flight to STL to KC and did not get that error. So, wonder if it’s scenery specific. In my case, something going on with the Chicago area?

please open windows event viewer and check the error message. In case you see somewhat like “grammar”, join here: 100% reproducible CTD at specific coordinates for months [grammar.pggmod]

Update: never happend again in the next 14 days since then. Could be a windows pagefile issue?

1 Like

I had it a couple of times with WU8 and I had it today as well with SU9 when I terminated a flight and clicked to return to main menu. RAM usage was around 30% at that point.

Cheers

I don’t remember, but it is possible I was flying out of KORD when it happened, but would not have been closer to STL. I haven’t had another, similar crash.

For those of you suffering from this issue; try setting ‘terrain pre-caching’ to ultra in the graphics settings.
Having this on a setting lower than ultra will limit the amount of stuff getting loaded into RAM, and will offload it to virtual memory. Most likely adding to the issue.

Sounds like a good idea. I have 32gb memory, so I assume it will hold a lot of pre-cached terrain. I’ll definitely give it a try!

Guys, it’s not due to any settings or hardware configuration.
If you read a little here in the thread, you will see that this error occurs with so many different hardware configurations that it is impossible that it is caused by a specific hardware. It is the same with the settings (MSFS or Windows settings).
This error also does not appear with any other 3D application.
It’s all in MSFS and Asobo needs to fix it.
So don’t go crazy with any registry hacks or things like that. This may help in the short term, but it is not a solution to the actual issue.

8 Likes

Well here’s a new one:-

And I wasn’t even running MSFS at the time!!!

1 Like

I know it’s not much help to anyone, but i thought it was worth mentioning the following.
I was suffering with these unexplained memory crashes now and again, which only seem to start for me after SU9.

Now i have just upgraded my PC last week to a AMD 5900x3d CPU, Gigabyte RX6800 16gb GPU, and Corsair 850w PSU, keeping the original MSI X570 pro M/B and the 32gb DDR4 3600 , being the only componenets left from the original system.

And i have not had a single blip since, I dont know what caused it, but i am thinking either the cheaper 750w psu, or even the AMD Ryzen 7 3800x . Thought’s

I think I can safely say it’s not the 3800x, mine is extremely well behaved even with PBO enabled. I did have these memory errors while running a gpu vram overclock and HAGs at the same time… but not a sniff of them since turning off HAGS.

1 Like

Thats intressting…

Navigraph Navdata Center.exe with same " memory could not be read " message.

Now that can mean that the other issues also caused from Navigraph , or these Application run in same issue because of possible same system-problem.

I’m plagued by this error multiple times a day still on SU9 is anyone on the SU10 Beta who knows this error, has SU10 made any difference ?

I have not had it so far on su10.

1 Like

These started today, don’t think I had them before. In the beta. Tried setting custom page file and auto-delete on startup. Didn’t help. Wonder if it could be an addon, got many installed. Just installed Flysinware’s Cessna 414, could be the culprit. Don’t think I’ve changed anything in Windows 11 or the BIOS before starting to get the errors.

EDIT: Countless hours later and I’ve finished reading through this whole thread. Phew.

Decided to leave the beta (required a complete reinstall).

Other things that I’ve done:
NDU “tweak”
Sysmain disabled
Game mode off
HAGS off
Removed Realtek drivers (I’m using Nvidia audio through HDMI)
Set audio in MSFS settings to Nvidia audio
Underclocked VRAM by 150. To be safe I also underclocked core clock to founders edition spec

MSFS vanilla, nothing installed, no world updates.
Graphics settings: 4K HDR all ultra v-sync off g-sync on terrain LOD 200

So far no memory CTDs (could not complete a flight before) and I just completed a 2hr+ flight. Next I’ll takeoff in the PMDG 737-700 for a 5hr+ flight, go to sleep. And pray that MSFS is still running when I wake up.

Interestingly, with these changes, in particular going from SU10 beta DX12 back to SU9 DX11 and underclocked GPU, the GPU usage has been very high - more than 90% average for the duration of this 2 hour flight. Which is over pretty remote areas of Uganda, Tanzania and Kenya in the default TBM.

My system: 12900KF (P-cores 5.0 E-cores 4.0 ring 3.9), Asus ROG Strix RTX3090 OC, G.Skill DDR5 6000MHz 32GB in XMP, WD Black SN850 2TB

Feel like I owe a post to this sub again, I had this problem for 3-4 months tried loads of fixes reinstalls nothing. But I have no fixed it by downloading Mai after burner, decreasing my hours clock and memory speeds by 150 and decreasing max voltage to 90%.

The game still runs stable maybe even better, and to comfirm this fix works when I boot the game without these settings active it crashes as usual. I hope this fix can help others