MSFS Application Error - memory could not be read

Now I have been performing the exact same flight and at some point the error gets triggered, however, in these last cases it would let me finish the flight with the error message laying in the background (I had heard it from someone else before).
Very frustrating and unacceptable.

image

I get this about once or twice a week now…Doesnt matter which plane, which airport, I got a new CPU recently but it happened pre and post install of that.

I’d say 90% of the time it triggers, it’s during a camera pan or fast movement of the camera (quick looks).

My setup:
SU9 (not in beta), 5800x3D CPU, 32gb 3600mhz RAM, 3080 GPU. No live or AI traffic, multiplayer set to all. No toolbar pushback installed, no AIG, no Google map replacement.

No issues with temps.

Paging file size (on C): 4864MB
Paging file size (on E, where my install is): None.

Registry:
ClearPageFileAtShutdown set to 1 (enabled)
Ndu changed to 4

1 Like

Another follow to my previous comment. I’ve voluntarily triggered it again (not that hard, just some crazy camera movements)…I noticed this happening to my system.

image

Red marks where the crash happened. Mainly note the memory usage went max usage. The memory usage didnt drop until I clicked OK on the message (green).

This happened as I was testing an underclocked GPU in afterburner, as I see some comments above noting to do so. So it doesnt seem to matter if over or under.

1 Like

I’m spending my sunday trying to figure this out apparently…I can summon this error at will, so it’s best to keep going and dig into it some more while the iron is hot so to speak.

How I initiate the error:
In normal mode - Live weather, any airport parking spot, any aircraft (cold and dark)
In safe mode (yes, this happens in bare vanilla MSFS) - Live weather, any airport and parking spot, C208 (cold and dark)

I just sit there, spamming camera movements (quickviews), left and right in the cockpit in rapid succession, possible in external view too.

The (possible) solution:

Set OFF SCREEN TERRAIN PRE-CACHING to ULTRA (General > Graphics)

In my case, i was mainly using HIGH…once I set to ULTRA, I couldn’t replicate the error anymore. Take a look at my CPU usage (in a SAFE MODE instance):

image

The green is when it was set to ULTRA. The red is when it was set to HIGH. I was performing the same camera movements for both settings. Note how unstable the usage was under HIGH…it didn’t trigger the error this time, however it does chew up the CPU a bit more. I also notice the camera movements under ULTRA had no impact on usage. It was consistent while doing them or not.

So while maybe not a foolproof method for everyone, something to consider, and something for Asobo to address (when OFF SCREEN TERRAIN PRE-CACHING is set to HIGH).

2 Likes

For those of you suffering from this error; try setting ‘terrain pre-caching’ to ultra in graphics settings.

A setting lower than ultra will load less stuff in RAM, likely offloading it to the virtual memory, maybe triggering this issue more.

1 Like

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

After some time FS crashes with error message: The instruction at referenced memory at . The memory could not be read.

Provide Screenshot(s)/video(s) of the issue encountered:

Screenshot 2022-04-14 192120

Detailed steps to reproduce the issue encountered:

Start flying and fly 15 min

PC specs and/or peripheral set up if relevant:

i5 12600K, 32GB RAM, 6900XT
Win11, OS & all drivers with latest updates

Build Version # when you first started experiencing this issue:

1.24.5.0

[/wrap]

Please mention what hints from the existing topics you already tried. Thanks !

https://forums.flightsimulator.com/search?q=memory%20could%20not%20read%20order:latest_topic

I had this last week. Restarting the sim does not solve it. Rebooting the PC clears it up.

2 Likes

Got similar the other day in 1.24.5.0:

The instruction at 0x00007FF7BF8F1EE4 referenced memory at 0x00000000000054C. The memory could not be read.
Click on OK to terminate the program.

It cleared up after a restart of MSFS, if I remember correctly.
Configuration: Asus Tuf Gaming X570 Pro Wifi, 32GB Memory, AMD 5600x, nVidia GTX 750 TI 2GB (that’s right, below minimum recommended) but it runs nicely.

1 Like

Got this error message twice this week. Saw it for the first time ever. Not reproducable. No beta user here. Tested my RAM, changed virtual ram from windows managed to custom settings. Did not got the error on today’s 2 flights that were 1,5 and 3 hours.

Got this message today for the first time. Not a beta tester. Rebooted PC and restarted FS everything then OK.
I7 32GB RTX3080

Yeah … it’s a quite annoying to reboot the PC (and reload the FS2020) because of this bug.

I just started getting this last weekend flying from St Louis to Chicago in PMDG DC6. Restarted system and sim and attempted flight again. Got same error at about the same spot (about 30min north of STL). Restarted system and sim and changed flight to STL to KC and did not get that error. So, wonder if it’s scenery specific. In my case, something going on with the Chicago area?

please open windows event viewer and check the error message. In case you see somewhat like “grammar”, join here: 100% reproducible CTD at specific coordinates for months [grammar.pggmod]

Update: never happend again in the next 14 days since then. Could be a windows pagefile issue?

1 Like

I had it a couple of times with WU8 and I had it today as well with SU9 when I terminated a flight and clicked to return to main menu. RAM usage was around 30% at that point.

Cheers

I don’t remember, but it is possible I was flying out of KORD when it happened, but would not have been closer to STL. I haven’t had another, similar crash.

For those of you suffering from this issue; try setting ‘terrain pre-caching’ to ultra in the graphics settings.
Having this on a setting lower than ultra will limit the amount of stuff getting loaded into RAM, and will offload it to virtual memory. Most likely adding to the issue.

Sounds like a good idea. I have 32gb memory, so I assume it will hold a lot of pre-cached terrain. I’ll definitely give it a try!

Guys, it’s not due to any settings or hardware configuration.
If you read a little here in the thread, you will see that this error occurs with so many different hardware configurations that it is impossible that it is caused by a specific hardware. It is the same with the settings (MSFS or Windows settings).
This error also does not appear with any other 3D application.
It’s all in MSFS and Asobo needs to fix it.
So don’t go crazy with any registry hacks or things like that. This may help in the short term, but it is not a solution to the actual issue.

8 Likes