MSFS Application Error - memory could not be read

Well here’s a new one:-

And I wasn’t even running MSFS at the time!!!

1 Like

I know it’s not much help to anyone, but i thought it was worth mentioning the following.
I was suffering with these unexplained memory crashes now and again, which only seem to start for me after SU9.

Now i have just upgraded my PC last week to a AMD 5900x3d CPU, Gigabyte RX6800 16gb GPU, and Corsair 850w PSU, keeping the original MSI X570 pro M/B and the 32gb DDR4 3600 , being the only componenets left from the original system.

And i have not had a single blip since, I dont know what caused it, but i am thinking either the cheaper 750w psu, or even the AMD Ryzen 7 3800x . Thought’s

I think I can safely say it’s not the 3800x, mine is extremely well behaved even with PBO enabled. I did have these memory errors while running a gpu vram overclock and HAGs at the same time… but not a sniff of them since turning off HAGS.

1 Like

Thats intressting…

Navigraph Navdata Center.exe with same " memory could not be read " message.

Now that can mean that the other issues also caused from Navigraph , or these Application run in same issue because of possible same system-problem.

I’m plagued by this error multiple times a day still on SU9 is anyone on the SU10 Beta who knows this error, has SU10 made any difference ?

I have not had it so far on su10.

1 Like

These started today, don’t think I had them before. In the beta. Tried setting custom page file and auto-delete on startup. Didn’t help. Wonder if it could be an addon, got many installed. Just installed Flysinware’s Cessna 414, could be the culprit. Don’t think I’ve changed anything in Windows 11 or the BIOS before starting to get the errors.

EDIT: Countless hours later and I’ve finished reading through this whole thread. Phew.

Decided to leave the beta (required a complete reinstall).

Other things that I’ve done:
NDU “tweak”
Sysmain disabled
Game mode off
HAGS off
Removed Realtek drivers (I’m using Nvidia audio through HDMI)
Set audio in MSFS settings to Nvidia audio
Underclocked VRAM by 150. To be safe I also underclocked core clock to founders edition spec

MSFS vanilla, nothing installed, no world updates.
Graphics settings: 4K HDR all ultra v-sync off g-sync on terrain LOD 200

So far no memory CTDs (could not complete a flight before) and I just completed a 2hr+ flight. Next I’ll takeoff in the PMDG 737-700 for a 5hr+ flight, go to sleep. And pray that MSFS is still running when I wake up.

Interestingly, with these changes, in particular going from SU10 beta DX12 back to SU9 DX11 and underclocked GPU, the GPU usage has been very high - more than 90% average for the duration of this 2 hour flight. Which is over pretty remote areas of Uganda, Tanzania and Kenya in the default TBM.

My system: 12900KF (P-cores 5.0 E-cores 4.0 ring 3.9), Asus ROG Strix RTX3090 OC, G.Skill DDR5 6000MHz 32GB in XMP, WD Black SN850 2TB

Feel like I owe a post to this sub again, I had this problem for 3-4 months tried loads of fixes reinstalls nothing. But I have no fixed it by downloading Mai after burner, decreasing my hours clock and memory speeds by 150 and decreasing max voltage to 90%.

The game still runs stable maybe even better, and to comfirm this fix works when I boot the game without these settings active it crashes as usual. I hope this fix can help others

To continue on from my post yesterday. To my surprise MSFS was still running when I woke up :slight_smile: Luckily I had enough fuel to set up for an approach. Everything went fine until final approach. Then I started to get heavy stutters to the point where the sim was unplayble. I turned on dev mode and discovered a ridiculously high main thread frame time (+150ms). I expected the dreaded “memory could not be read” error. Instead, I was able to land (with terrible frame rates). A few seconds later I got this and a CTD:

So in a way very good news for me, as I’ve now completed a +2hr and a +5hr flight without the error mentioned in this thread. The of course not so good news is that I discovered a new type of CTD…

Next step is to restore the GPU to the default values and try a 3,5 hr flight.

Another point of interest though is that although my Asus RTX3090 is stock overclocked, that only applies to the core clock. Memory clock is the same as founders edition. So I’m very curious if resetting the GPU to default will reproduce the “memory could not be read” error.

And there it is! As mentioned I reset the GPU to default with MSI afterburner. Just a few minutes into the cockpit preparation in the FBW A32NX at NZA Simulations NZAA:

Decreased memory clock by 100MHz and restarted the flight. After less than a minute:

1 Like

Cool, can you please share your afterburner settings? I want to try this too, now i am going to test this with the terrain pre caching to ultra and navigraph disabled at the startup. Thanks

@Dynarith Well it depends what GPU you have. I have a factory-OC’d Asus ROG Strix 3090. It seems underclocking the memory is not enough to avoid the CTD. Also have to underclock the core clock. With both underclocked, this could be the remedy for this CTD - for me. Anyway, here’s my Afterburner:


So you’ve also been able to fix the CTD by underclocking your GPU? We might be on to something here, I think. Of course there could be other causes for the CTD. But it seems I’m able to reproduce the CTD. With stock (OC) clocks, I get a CTD within minutes of starting a flight. Underclocked core and mem and I can fly for hours with no issues.

1 Like

Yeah nothing would fix the problem for me until I undeclocked my gpu, I’ve been able to play intensely for around 4 hours without any problems, I have a 2080 super so maybe the more powerful your card the more you need to under clock

The memory modules on the 3000s is error correcting, so overclocked memory won’t artifact or throw errors. This is a big change from prior generations, where artifacts would occur when memory is clocked too high. If the overclocked memory is pushed too hard on the 3000s, it will recalculate the error in an attempt to avoid artifacts. This will result in reduced performance, and gets worse if more errors are thrown. You can see this in benchmarks - results increase until a certain point, then will decrease significantly.

I don’t think your issue is caused by overclocked memory.

You could be correct. Next step is to leave mem clock at stock but with an underclocked core clock to see if the CTD re-appears.

I’ve filed a detailed Zendesk report to Asobo.

1 Like

People tend to get offended when I mention this, but this type of error tends to highlight some type of hardware flaw. Could be bad system memory, defective CPU, etc. Have you ever tried checking the memory for errors? A program like Memtest86 is easy to run overnight.

Also, do you have any WHEA events in System Viewer within Windows? Some type of memory-related WHEAs can throw errors, but not cause a complete system crash.

1 Like

yep, thats unfortunately the case. We have lots of reports about reducing RAM speed and / or GPU speed and the issue is gone. A possible hardware issue or somewhat with the driver, in special related to the 30xx card, we suspected long ago, but the answer from users is often only “in other games all works fine”. At least there must be a reason why the most users never seen these error and the votes are also not in a range if there would be an issue with the game in generally ( and the same error report but for Navigraph.exe also point to that ).
If we would find at least one situation where it ensured can reproduced, but thats not the case.

1 Like

Yea, this one is interesting. It might be that MSFS is highlighting hardware flaws better than other games. For example, I can overclock my 3090 core to +60 Mhz in MSFS, but anything higher than +60 Mhz crashes MSFS constantly. In some games and even benchmarks, I can push that same core offset to +150 Mhz without any issues. For some reason, MSFS is picky on a GPU core clock.

People are quick to blame Asobo, but I have personally never seen this error with my rig.


Not sure who you’re replying to, but in my case I’m in the process of reproducing the CTD when leaving my GPU at stock clocks. Not sure how this relates to system memory and CPU. Unless you’re speaking in more general terms.

1 Like