MSFS Application Error - memory could not be read

Ok, thank you very much, it has been a great help

2 Likes

Another CTD this morning, this time without the “memory error” message BUT, I have inspected the windows event monitor and the cause is rooted to the same file (ntdll.dll) than the other 2 crashes of yesterday with the “memory error” message.

Blockquote Nombre de la aplicación con errores: FlightSimulator.exe, versión: 1.26.5.0, marca de tiempo: 0x00000000
Nombre del módulo con errores: ntdll.dll, versión: 10.0.19041.1806, marca de tiempo: 0x1000a5b9
Código de excepción: 0xc0000374
Desplazamiento de errores: 0x00000000000ff609
Identificador del proceso con errores: 0x4b74
Hora de inicio de la aplicación con errores: 0x01d8b4827950166c
Ruta de acceso de la aplicación con errores: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Ruta de acceso del módulo con errores: C:\Windows\SYSTEM32\ntdll.dll
Identificador del informe: bd20ba6d-1d8e-4ae3-b0ef-6eb67314d748
Nombre completo del paquete con errores:
Identificador de aplicación relativa del paquete con errores:

Blockquote Depósito con errores , tipo 0
Nombre de evento: APPCRASH
Respuesta: No disponible
Identificador de archivo .cab: 0
Firma del problema:
P1: FlightSimulator.exe
P2: 1.26.5.0
P3: 00000000
P4: StackHash_56ea
P5: 10.0.19041.1806
P6: 1000a5b9
P7: c0000374
P8: PCH_21_FROM_ntdll+0x000000000009DA94
P9:
P10:

I even tried to do the “sfc /scannow” to see if it solves the problem.

Happens quite frequently here too, sometimes the error message will pup up but MSFS continues to work, only the dam error window is forever there till I click ok then MSFS closes, 95% of the times, CTD instantly, so frustrating. Also only been happening since the last big update

Nope, still another crash and without IVAO (the other 3 was online on IVAO) and no AI traffic, no multiplayer planes.
I will try with other plane to see if maybe it’s the plane (It was FENIX A320), but I am really tired that after 2 years, this is still “Microsoft Debug Simulator”

EDIT: At this point I don’t know If I should do another post about this crashfest that started yesterday (and I didn’t update anything or installed any plane or mod to the sim or changed any config of my system or MSFS)

EDIT2: At least now it didn’t say that the crash is caused by ntdll.dll. Coincidence maybe? :thinking:

Since yesterday.
Short flight with SR 22 manual and IVAO : ok
Medium Flight with A20N (fbw) and IVAO (between malta and genava) : crashed over alpes
Long VFR Flight between with BE58 and autopilot and IVAO : crashed after take off, then after 2 hour flight when switch AP mode NAV to HDG

This morning :
Another try to my IVAO A20N flight : chrashed over cicilia when change AP altitude
Short VFR flight with SR22 on IVAO : ok
Short VFR flight with SR22 with AP and IVAO : crashed short after take off.

So, for now and my experience
2 flight without AP : no crash
5 flight with AP : 100% crashed at different moments.

can be random… the ntdll.dll / 0xc0000374 can also happen in case of map-issue (.e.g. ) or others . Are you sure that the error message “memory could not read” correlates to that ?

1 Like

And the read error is back… Fenix & MSFS having been stable for quite a few days. Fed up with it. 4 sticks, 2 sticks RAM makes no difference. XMP or no XMP still results in random read error. could be days apart, or hours apart.

Ran some more tests and passes every time.

Wait… mine was “could not be written” :thinking:

Maybe we should start another thread about this bug then. This make it unclear to have relation with the bug of this post, sorry.


Some of us are starting to thing that maybe is a Fenix related issue but… the crashes didn’t totally correlate with Fenix. People are having them with other planes.

1 Like

Some interesting information from Matt…

Memory cannot be referenced - Microsoft Flight Simulator (2020) - The AVSIM Community

1 Like

I have them with all kinds of planes, in all places. Doing a round the world trip and changing planes depending on the legs. I’ve had this all the way from Jakarta to Toronto, in SU9 and SU10. Payware planes and default planes, it’s the same. 100% vanilla sim, no addons = still CTDs.

I didn’t have these before upgrading from a 10900KF to a 12900KF and at the same time switching to a z690 motherboard with 32GB of DDR5.

What I’m not sure of though, is if I had the CTDs before upgrading to Win11. I simply can’t remember…

we have an ( better more ) existing topic about " … written" :slight_smile:

Also, have you seen the other topic which I linked to your post. Other users report same ntdll issue and/or at least more CTDs in last days in generally.

So, may be “yes”… its may be not related to that issue here ( what my guess was too :slight_smile: ).

And yes… what I read in that topic, it is independ of the airplane.

1 Like

just got this again with the Fenix on approach to PMI… back to square one :frowning:

i’m afraid XP12 is my only hope can’t be dealing with this buggy game anymore

CTDs are increasing at the moment. Yesterday four times. Today at the first flight after 15 minutes and after restart again at 30 minutes flight time.(WIN10, CJ4 working title KBOS-CYFC)

Those of us who have this problem that did not exist before, what operating system I am with win 11, maybe something was loaded in win 11 or maybe the NET Framework

these question exist often ( both OS are affected) and also the guess about possible issue within a system lib, -api, etc ( also .net ). We try some time to compare system for users without these issue ( e.g. my ) and users system with that issue.

Again today 3 times for me now and last time CTD without any warnings in cruize mode. I will try in another place to see…
I’m on windows 11. last update Net framework (KB5015732).
All was working perfectly until yesterday 19.08.2022 everytime memory could not be read…

a note: we trying to collect the CTDs ( NOT the “memory could not be read” ) of the last days within these topic: Constant CTD every flight now . In special if you get the " ntdll.dll / 0xc0000374 " error in windows event log, please report back in that topic ( also some additional info, like steam/ms-store, etc ).

1 Like

Ok understood Last CTD I have no error in the event log only this in .Net Runtime but it was the same error with the memory:
Application : FlightSimulator.exe
Version du Framework : v4.0.30319
Description : le processus a été arrêté en raison d’une exception non gérée.
Informations sur l’exception : code d’exception c0000005, adresse d’exception 00007FF6CF2F6020

1 Like

Just had a CTD in the middle of a flight. Then a CTD after starting the sim again, while the sim was loading. So that’s new. How do you find information in event viewer? I’m not familiar with that program.

I tried yesterday to use DX12 and this has seemed to help quite a bit for me anyway. Whereas before in DX11 it was every flight and usually in the same region of my test route, yesterday I completed a full flight and today completed two full routes with a roller landing at EGCC, RTB’d and rolled straight back into another cycle of said test route. It was only after three hours or so and back on short finals into EGCC that it went belly up. So. Around 70 to 80% better for me on DX12.