MSFS Application Error - memory could not be read

Devs should be upgrading the code instead of users downgrading their hardware. So this I would say is a software issue.

1 Like

an isssue which get unfortunately only some users and we try to find out whats different to the systems which not getting the issue… Discuss about who should do what is may be not very helpful here. If you have the issue, you can share infos about your system, installed software, steam - ms-store, etc. It’s may be also helpfull if you share your systems specs in case you not get the issue.

I have a Dell XPS8930 with 16G of ram. NVIDIA RTX 2060. Nothing overclocked or tweaked. Running windows 11, latest updates/patches. I just bought MSFS2020 from the App Store a couple of days ago…thought it would be a nice upgrade from Steam MSFS X… but after it autoloaded many many updates/fixes during the install process…every time I try to fly I get a memory error, similar to what you all are getting.

VERY frustrating. I was debating MSFS 2020 or X-Plane 12 (out soon)…I guess I may have jumped on the wrong plane…sigh…

1 Like

Seems an increasing number of people are reporting CTDs in various threads here and on Avsim. Of course there could be some common denominators (like everyone running MSFS…) but the sim at the moment seems fragile.

Could you ask a reimburse to MS Store and buy the FS2020 Steam version? and try and tell us if there is a difference regarding in those errors?

I just had a memory could not be read this evening after almost 6 hours… … … …

with the 0000000000000 error this time, with some snaps of sound (maybe when the ATC was going to speaks?, ATC sound related? I have it in automatic responses from copilot) before the Sim, not the PC, got frozen, though its sound continued, and I closed the memory advise and the sim closed immediately itself after. I have using the motherboard inbuild Realtek soundcard, maybe I try with the ■■■■■■ sound of the monitor and only the NVIDIA sound output, if it is something related, who knows, I have checked and tried so many things and workarounds.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

NO

Have you disabled/removed all your mods and addons?

YES

Brief description of the issue:
I have now received this for the second time, the last time was 2 weeks ago.

image

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Build Version # when you first started experiencing this issue:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

If on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Check the sound devices configuration in Windows - Settings - Sound. It keeps getting messed up by Windows update. For the “memory can’t be read at 0x0000000” this is often the cause. Memory errors at other addresses are a different beast.

BTW, I am a big fan of all your videos!

Yes. Make sure the default audio output device is the monitor itself if possible. Make sure it is NOT a Motherboard, Windows, or Video card audio mixer device.

This is a super frustrating error and made worse because of Windows update which keeps messing with these devices for reasons unknown.

1 Like

I tried again today…I upgraded to the latest NVIDIA game-ready driver (The one I had was a few months old)…and I increased my windows paging space from 16GB up to 30GB…launched the game from the nvidia game-ready menu…and it seems to work now…

Not sure if it needed the nvidia update, the nvidia launch or the increase in paging space…hopefully it will keep running.

My sound devices output and input are my headphones. If I make it the monitor itself it sounds awful. Am I meant to fly around with monitor sound? how do I communicate?

That should be fine. Does Windows think they are the default audio device?

You might also try trying picking the monitor to see if the CTD goes away. That said, I don’t think it matters if it is the monitor or the headphones.

Mark

The last few days I seem to no longer experience CTD issues. I still have my complete Community folder active but I haven’t touched FSRealistic and the Clear Air Turbulence app (both loading externally with MSFS).

All online features on again, except for ATC as I now use PRO-ATC SR.

Saturday I even had four flights with the Bae146 in one MSFS-load, going up and down a few hours on multiple legs around some pretty heavy Stockholm scenery and everything was fine for now.

Hi, Since I have SU10 Beta, I no longer have this error with Ram error

1 Like

I havn’t had any errore since 10 or so flights, yesterday the error shown up again during a thunderstorm (irl) that has caused a loss of bandwith in my internet connection (i have only access to the sat internet as i live in the middle of the alps) i am starting to think that this may also bandwith related

1 Like

Be careful too with the GPU´s overclocks, core and/or memory, that could be much over of your official OC speed, my GPU core speed in “stock” with MSI Afterburner it was around +220Mhz more than the official webpage stock OC specs, a reason for errors etc., my GPU mems speeds were well.

Good point. My GPU is factory OC’d by 165MHz compared to founders edition.

What’s the progress on this issue? Will the coming Update fix this?

scroll up and read will helps :wink:

Thanks. That’s very helpful.

1 Like

This is happening alot. Hopefully simupdate 10 will fix this and a new Nvidia update patch

1 Like