MSFS Application Error - memory could not be read

Nothing, for me is the same, thanks anyway for the help.

Well two flights in one of two odd hours another of 2 hrs no problems using AIG and fs realistic on FBW A320

Now I have been testing clean mem on one flight and ISLC on the other flight to keep memory in check

Also made sure my audio is synced ie: windows 11 and msfs both using same audio and it seems to be fine

Will do another flight today with ISLC installed and all other applications running with maybe the PMDG 737 to see how that goes

They guy who created ISLC is the same guy who created DDU and there are numerous you tube clips on it so snake oil or what it seems to be working for me ……at the moment as a workaround as I don’t think this is going to get fixed any time soon by Asobo: Microsoft

1 Like

I seem to have fixed my problem by changing from using the Nvidia sound driver to using the onboard Realtek sound drivers.

Previously I was using the Nvidia sound to output through my monitor speakers (over the DisplayPort). I changed to using the onboard motherboard and the simulator is now very stable.

I am curious how many other people are on Nvidia GPUs and using the Nvidia sound driver. I had previously tried changing my sound in game to match the windows output settings but this made no difference (when using Nvidia sound).

Now I have Windows set to output to the Realtek sound and Flight Sim to use the “Systems default device”.

I am interested if changing away from using Nvidia sound has a positive effect for other people.

Windows 11
AMD Ryzen 5950x
Nvidia RTX 3080ti (running latest Nvidia Game Ready driver)
32 GB RAM
M.2 SSD

I didn’t have this problem until I reinstalled the system. Sim works normally in the menu. Once it will ctd while loading, another after a few seconds on the ground. At the default aiport with Cessna it’s ok. If I load 737 from pmdg at any addon airport it crashed every time randomly. As I wrote earlier, it was temporarily helpful to change the audio output. Why it was so short I have no idea.

1 Like

Hello candycatx!
What is an NDU patch? Can you help me understand? Thank you very much!
Gábor from Hungary

1 Like

(NDU registry change) Increase performances immediatly! AMAZING! Tested and aprouved!

Hi Gabor,
Hope this helps

Best wishes

1 Like

That might be because of screwed up audio settings when you reinstalled, check windows and msfs are using same audio

Good luck

Thanks! :slight_smile:

So, tried it and just got an “memory could not be read” error anyways. So it might be helping with the memory leak, I don’t know, but it doesn’t prevent the memory read error.

How did you confirm/identify a ‘memory leak’?

of all the issues I’ve had with MSFS2020, ‘memory leaks’ isn’t one. It seems pretty Frugal with it’s RAM allocation and usage.

because this clickbait video, million times mention within the forum, have nothing to do with " memory could not be read". These error-message is also not a memory-leak… Users mentioned system-configuration issues ( sound ), RAM issues like XMP mode, or there is realy an issue with the game ( but then still not clarified why only some rare user get this ).

Don´t forget to subscribe, tick the little bell, and SMASH! the vote button.

1 Like

That video didn’t claim it would fix that memory read bug and I didn’t believe it would. I just wanted to make sure. I think pretty much all supposedly solutions people have posted here are voodoo and mean nothing since the error is very random and erratic and can disappear for a number of flights only to return 3 days later for 3 flights in a row.

I also wouldn’t say that a thread with almost 650 postings indicates that “only a few user get this”. It is very much a heavy problem a lot of users have. It is very much a problem of the sim, especially since people seem to have it in all kinds of circumstances like mid-flight, just starting the game, browsing the in-game shop etc. with all kinds of addons and hardware configs.

I not think that all are vodoo, in special the sound-device solution ( and I may be xmp too, as some users reported )… But yes, the final reason seems not found / determined. It can be random that the problem comes more on top with SU9, just because there are also lots of e.g windows updates in that time, but of course we not know it.

Ah… and, the votes is what count, not the amount of postings ( the conversation )…

1 Like

Sound yes
Xmp , no
Ram , maybe as it seems to be using a lot more ram looking in task manager
But who knows, it’s as you say the votes that count

Might be a long shot but in ain’t gonna fix itself right? Although I didn’t encounter this error myself I came upon this announcement from Microsoft regarding memory leaks and crashes. They offer a cumulative update (fix?) that addresses “memory leaks and crashes”.

  • I suggest you only try it if you know how to roll-back an update / patch like this one.

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

2 flights in a row in different areas of the map, a CTD with error code 0x00007FF6D1980328 appeard

Provide Screenshot(s)/video(s) of the issue encountered:

image

Detailed steps to reproduce the issue encountered:

starting descend into airport:

  1. CTD: Descend into LFSB
  2. CTD: Descend into EDDP

PC specs and/or peripheral set up if relevant:

  • Intel i9 10900k, RTX 2080TI, 32GB RAM
  • Thrustmaster T1600 joystick
  • Logitech Saitek Rudder Paddels
  • Fenix A320 Aircraft
  • LFSB & EDDP Payware addons

Build Version # when you first started experiencing this issue:

latest


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Would report back if something happen in the meantime since the XMP change I wrote earlier. (see post 612) Nothing did happen and the issue did not return since I’ve adjusted XMP profile and deinstalling Aerosoft Simple Traffic. Although it did work for me, I don´t see why the fix does work for me as it currently doing. As it does not make sense and MSFS is the only program that acts up like it does.

Since changing it is now already the 3rd day without memory errors sessions. Probably gamed this friday as I was free and past weekend for something around 8hrs+ per session.

1 Like

it affects users with Windows10 and Windows 11 so that is probably not the problem
but anyway thanks for the hint

1 Like

It is happening on 22h2 also however I haven’t had this error for couple of days
Was flying the FBWA320 and memory was high but it was using 16gb of my 32gb
Interestingly I flew a short flight on the PMDG 737 , at times resource monitor went up to 98% of my ram , but then it slid back down thankfully to around 9gb then it would rise up again and just at the point I thought it’s going to CTD it fell back again
Landed fine and taxied to gate , then memory was at about 10gb
Never before have I had it ever go up this far and virtually max out 32gb so it’s obviously a msfs /Asobo issue