MSFS does not enter VR mode during the Spruce Goose Anniversary Flight

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

No

Brief description of the issue:

Currently using Rift S flying the Hercules H-4, the game does not enter VR mode for me, but only during the anniversary flight activity from Long Beach. I can see the game in the Rift S but its only showing up as a windowed view. Both entering the flight in normal and switch to VR or entering VR mode before loading up the flight, neither works. Tried other plane(the Helicopter mission) and it seems to work just fine in VR.

Flying the Spruce Goose in Free Flight does not have this issue.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

12700K, 3090 Ti, Rift S, latest current nVidia driver

Build Version # when you first started experiencing this issue:

1.28.9.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Same issue with Quest 2, can’t be replicated in any other new or existing planes.

AMD 5900, 32gb, 3090fe, Windows10, latest Nvidia l driver, Quest latest drivers, with openxr

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hello,
Which “goose” are you flying? The Grumman G-21 Goose or the Hercules H-4 Spruce Goose?

Sorry I realized afterward that I was talking about the Spruce Goose as opposed the the Grumman Goose…

Ahh, no problem! I’ll just add that to your title and tag it appropriately.

Unfortunately, I don’t have a VR setup to be able to check this out, myself. But hopefully someone will!

Also have this issue (discovered when trying the new 40th Anniversary Activities). It also does not enter VR when using the Wright Brothers plane.

Quest 2, 3080 on latest drivers, 9800x.

Both planes work for me in VR in Free Flight on a Nvidia card (drivers 526.86) and a Quest 2.

I also have same problems, not being able to fully enter VR mode (stuck in infinite space view with large screen view), for Spruce Goose and First Kitty Hawk flight 40th Anniversary activities. Not found this problem, so far, with any other activities.

G2
Win 11
Nvidia driver 526.86
RTX3090
i9-10900

Same for me, both the Wright Flyer and the Spruce Goose only Enter a VR “Cinematic” Mode, not full VR.

Reverb G2
Win1122H2
RX6800XT (22.10.2)
5800X3D

Ok I didn’t think to try the Spruce Goose outside of the 40th Anniversary event, when I just flew it in free flight it had no issue with VR. And when I went back to try it in the event, still doesn’t work it that.

So its a event specific thing.

Also tried the Grumman Goose and no issue with that…

You could modify your post title to add the fact that it only happens during the Activity :+1:

1 Like

Hi,

I could not duplicate the OP’s issue. So far all aircraft work fine in VR using my Pimax 8kx, including the Hughes H-4 Hercules aka Spruce Goose.

I’ll go back to try all the event flights later tonight.

You checked during the 40th anniversary Activity and not in Free flight?

Repro for me during the Activities.

PLEASE vote at the beginning of this post if you do have the same issue. Thanks!

1 Like

Yep only the 40th anni event has the issue, when I do free flight no problem with VR.

Hi,

TBH, I just now used the Activity section for the first time. And yes, there is a problem with the Spruce Goose when trying to switch to VR.

Voted.

Update, tried a few of the Anniversary events, with the A310, Cessna 172, etc, none had issue with VR…

This is in our current Known Issues list a well as some other known issues in Activities, which means the issue is logged internally already.

  • Issues with the default VR position in the following 40th Anniversary activities.
    • First Flight at Kitty Hawk
      • Workaround:
        • To work around this issue, a user has to select the Pilot camera in the flight panel.
    • Spruce Goose
    • First United States Airmail Route
    • The Hell Stretch
    • The default view can sometimes spawn a user in the fuselage, or the VR view can sometimes fail to initiate.