MSFS Launches MS Store for Gaming Services

Ok I can’t start MSFS 2020 because of this very same issue, what the hell ???

:angry:

@MSFSRons suggestion (thanks by the way) doesn’t work :frowning:

Edit : MSFS 2020 started by using the Xbox app instead of shortcut.
But what a mess, it’s not the first time an update messed up my installation.

Edit N°2 : Shortcut working again now as well …

I too have this problem > launching the MSFS Icon takes me to the Microsoft Store and the Game Services app page. tried deleting the Game Services registry entries, tried uninstalling and re-installing Game Services, launching from Xbox software, resetting or repairing Game Services App.

My community folder is empty.

I guess a reinstall of FS is necessary which is disappointing as its been working pretty much flawlessly since release date.

Solution is to run the windows media creation tool and reinstall base windows 10 apps

(keep your installed apps and data)

Worked for me perfectly :+1: no need to reinstall MSFS

Do not reinstall FS2020. This is useless. I have already done it 2 x and after 2 or 3 days the problem returns. It’s a shame this simulator. Permanent waste of time.

3 Likes

Same issue here. I am tired of MS Store issues.

1 Like

This is so beyond ridiculous. Just had this issue a week ago, today I needed to apply the same registry hack again to make it work (Unable to launch FS2020 ---> Store - #13 by QuickNiq).

Microsoft, can we expect to perform this Registry-Hacking Mini-Game now everytime you “update” your “Gaming” “Services”? I’m so fed up by this. Never had these kind of OS / 3rd party issues with any other game (well, okay, maybe Rockstar titles).

And, by the way, there is still no trace of Sim Update 4 in the MS Store for me as of today! What’s going on with that rollout??? (Sorry for going off-topic… This is all so frustrating I have to use these forums as a place to vent.)

1 Like

Thanks for the link. It worked to remove both entries from the registry and restart.

Guess we are in the same boat at the moment as I am also not offered any SU 4 so far.
Probably this is related to the same issue.

From past experience, I guess, it will be another reinstall sooner or later to get everything lined up again and then hope it will last two or three updates before it will start all over again.

I assume it is all related with Microsoft´s DRM, account and encryption madness.

Luckily I only have 4 games with MS Store and they ALL have been causing issues on a frequent basis. I have no issues with the approx. 400 games in steam, epic, origin, ubisoft and/or gog.

In general, in over 35 years, the only times I ran into trouble in the past, only was with “Games for Windows Live”, which was also Microsoft.

I have no more hope they will ever improve their “service”.
So all I can do is limit my purchases/risks to the absolutely minimum and avoid MS Store wherever possible. Though this is quite sad, what else can be done…?

1 Like

I did it also. New re-install of Win 10 via the Media Creation Tool.

Hi GothicHeart77,

Did you have any luck with your Sim Update 4? If not, you may try the solution I posted here.

I cannot promise it will work on your system, but it worked on mine.

Same issue here, cannot start MSFS anymore. Will try to reboot… Nope, reboot didn’t help. Whenever I start MSFS the Store is opened and it tries to install Gaming Services but it fails :frowning_face:

image

It is not trying to install “Gaming Services” unless you deleted/uninstalled it from Windows 10.

The “Launches” Topic title is misleading.

It is usually wanting to install an “update” to Windows 10 Gaming Services.

Solved it by a regedit hack.

Hi,

thanks I will maybe try later today.

To be honest, I am still not happy with these “workarounds”. It is 2021, MS applies hundreds of restrictions on my PC installations claiming it is the best that users do not temper around with the files for their own sake.

And when MS is not able to update its very own program - instead of providing support or stating something official or providing a patch, it is expected that ppl start hacking their registry entries manually…? That´s not the way… And don´t tell me about hundreds of configurations and stuff - tthis might be true for the Flight Simulator issues, ok - but this is just a service program by MS and has nothing to do directly with FS.

Still, I appreciate the help of course. But I also do not want to risk my system´s stability in the long run, because MS maybe was not able f.e. to close their own service program before trying to update it (just an assumption of course).

One tipp from my side:

After the Gaming Services update was done correctly, it can happen that all MS Store apps are greyed out or give an statement like “is offline” or “There was an issue, please re-install”. The best way here is to WAIT. After some time, it recognizes the apps again without any need for reinstallation.
This was also true in the past for me, if it might happen due to other reasons. Again, the MS “information” / “error statement” might be misleading for such cases.

1 Like

I get where you are going with this, Gaming Services eventually seems to have corrected (after a couple of weeks), however game would still not run. Have deleted MFS and was looking to reinstall… guess what, wont download. Seems as though there is a program inhibiting the download.

Its a Microsoft product using Microsoft Windows, you’d think…

Unfortunately, we are all paying the price for Microsoft’s near monopoly in operating systems. If Microsoft had healthy competitors, no one would put up with “gaming services” creating a problem for loading a program which was already purchased (and operating fine before the latest update). This should not be a do it yourself project for computer geeks. I don’t want to hear about how to “fix” Microsoft’s problem; I want Microsoft to fix their own problem and not cripple my use of a program already purchased. Such is the stuff that lawsuits are made of.

1 Like

Give this a shot. It has worked for others.

Use the WIN+R key combo to open up a run box and in that box type wsreset.exe and press ENTER. It will open up another window and it may look like it isn’t doing anything, but let it run. Give it at least a minute. When it is done, Microsoft Store will open up. Click on the three dots in the upper right and select Downloads and Updates. Then click on the Get Updates button.

This worked for me :

Source : Error Code: 0x80073D26 Cant install Gaming Services in Microsoft - Microsoft Community

Open Registry Editor

Go to HKEY_LOCAL_MACHINE → SYSTEM → CurrentControlSet → Services

Remove the GamingServices and GamingServices.Net

Restart Computer

Go to your Windows Store → 3-dot-menu → Downloads and Updates → Check updates

Gaming Services should install now without issue.

Double check by rebooting and going back to Windows Store and trying to Get Updates again - you should be Up to date.

3 Likes

some special people on here, omg :laughing:

That’s not entirely fair. Not everyone can be expected to be computer literate in all aspects.

Thanks, this helped get rid of the error on installing that ■■■■. However, once I did that restart and opened up the store again, Gaming Services wouldn’t update. It just says version 2.53.17003.0 is installed. Is this the latest one? Or did I break something and now GS will never update again? The sim starts right up, though. So I’m alright with that …

1 Like