MSFS load stalls at New Activities screen

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons?

There are no mods or third party addons. This is a fresh install.

Brief description of the issue:

My MSFS 2020 is a Windows Store PC install. It is fresh, no addons, etc. I just built a new machine for MSFS 2020. The sim has never worked. I have never been able to fully load the sim successfully. I get as far as the New Activities screen (where the mouse disappears and the blue progress bar at the bottom completes), then nothing more happens. It does not appear to crash, there is simply no more discernable activity. The sim is stalled.

I have tried several ideas from the internet and even from this forum. I have rebooted the machine, restarted the sim, started the sim as admin, gone into settings to try Repair, Reset and Uninstall. I ran repair on the Microsoft Store. I have uninstalled and reinstalled several times. I have verified all updates for Windows 11 Pro and Nvidia. I even bought and installed a second nvme 2 TB drive and installed the sim on that. No change effected by any of these attempts. The sim continues to behave in exactly the same way.

The other notable software titles installed are Office/Outlook, Visual Studio Code, Visual Studio 2022, SQL Server Management Studio, Firefox and Star Wars Jedi Knight II Jedi Outcast (yes, that’s an old game but still fun). BTW, the Star Wars game loads and runs fine.

The only steps to reproduce I can offer is to just try and start the sim. I am not doing anything else, except sometimes trying Run as Admin. No difference. I never get to the sims starting screen, so I have no access to its menus or anything.

I’d appreciate any suggestion as to how to proceed. I simply don’t understand why this thing won’t load. All my hardware is well within requirements and I have 4 TB of drive space not counting other installs. Thank you all in advance.

See below for spec details.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Processor 12th Gen Intel(R) Core™ i7-12700K 3.61 GHz
Installed RAM 64.0 GB (63.7 GB usable) DDR5 4800
Graphics Nividia GeForce RTX 3090
Nvidia driver version 516.94
System type 64-bit operating system, x64-based processor
Edition Windows 11 Pro
Version 21H2
Installed on ‎9/‎6/‎2022
OS build 22000.978
Experience Windows Feature Experience Pack 1000.22000.978.0

Build Version # when you first started experiencing this issue:

what is noted above


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hello @CozierZulu25283,
Did you install the Xbox app? Or if you did, assure all apps are current by doing an update check from the MS Store.

Hello @Hester40MT
Thank you for responding. I’m new to this, sorry if I miss something. I have the XBox app, it’s running. I just clicked Check for Updates with no visible effect. I ran Get updates in the MS Store with several getting small updates, but nothing happening for MSFS.

If anyone comes across this post… problem solved. I actually got the idea from another poster on this forum. The problem is not my machine. The PC I built is fine. The issue is with Microsoft, and possibly Osobo. There is a server error causing the load and startup of FS to hang. The solution is simply to unplug from the internet and reconnect. That’s it. Just unplug the RJ45, wait a second then plug it back in. This is only a work-around. Hopefully MS fixes this soon. But for now this does the trick. Cheers.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I am having the same problem. It was working fine a couple weeks a go but when I went to use it froze at the New Activities screen. I reinstalled FS2020 several times but it still does it. I reapeat it was working fine a couple weeks ago.

Hello, yes, sounds like the problem I was having. I would get stuck at New Activities, the progress bar would complete but I wouldn’t get any further in starting the sim. Like I said above, I stumbled across a work-around: just unplug the RJ45 to disconnect your PC from the internet, wait a second and plug back in. When I do this, the sim instantly jumps to where it should have been already. I don’t know what the problem is (I’ve read Microsoft servers are a likely culprit), or when they’ll fix it. But for now this hack works well enough. Certainly does the trick for me. Enjoy flying! Cheers.

I to have the same problem after Service pack 10 , funny how as soon as you disconect the ethernet cable it proceeds to the start screen then pluging it back in and everything works , a pain but atleast we can fly , must be something stupid i hope MS and Asobo can solve

Same problem here