MSFS Long random freezes at all stages

I was getting this before the latest UK update but it is even worse now. At various stages from the moment I start MSFS through to during a flight I get random long freezes where the program shows as ‘not responding’ in Task Manager. If I leave it for a few minutes it will eventually come back to life.
I have tried emptying the Community folder but this makes no difference.
In task manager performance no particular element, eg GPU, memory, CPU, is showing as maxed out apart from Power Usage which is Very High
This freeze can happen at any time…eg initial loading screens when program first started, in the menus while I am setting up a flight, and once I am in the flight. It has pretty much rendered MSFS useless.
Any help would be much appreciated.

Give us some info… What’s the spec of your machine ? What’s the CPU and graphics, how much RAM do you have, how much harddisk… or SSD ? How much is left… have you tried empty the cache, then leave the game, then restart the game and make a new cache ?

System is i7-8700k, 1080ti, 32GB Ram, MSFS installed on Samsung 970 EVO Plus M.2 SSD with 378GB left.
Have emptied cache etc.

You may be interested in this thread.
Seems you aren’t the only one.

1 Like

Thanks for sharing :slight_smile:
Mine isn’t so much frames performance, which when its running is pretty good, it’s that the sim freezes and can happen during a flight, in the menu system when you are putting the flight together and even after double clicking on the icon to start the sim up. During this time it is freezing in displays in task manager as not responding but will periodically be ‘responding’ in Task Manager but still frozen on screen. Then all of a sudden it comes back to life.


Sadly I think that “debugging” performance causes in this type of game … a highly complex bleeding edge game system … is a pretty “tricky” job.

I for my part have seen this today:

  • I copied some screenshots from my SSD to a USB stick … while flying
  • … and during the copy job the flight started to “frame stutter” really really badly

I think I did that copy-thing in previous release too, and I have never seen such stuttering before

But … a number of OS subsystems have been updated … the AMD driver got upgraded … etc, etc.

The interdependency of all those software components all over the software stack … down to the drivers and the hardware … it all is so complex that while I can observe the (new) artifact I do not dare to guess which piece of software is responsible for what.

I do not envy the folks who have the task of fixing such issues.

This may apply.

Yes … it kind of points to a similar issue: Low level system drivers (with basically zero CPU load) can have a dramatic impact on the games performance.

IMHO Jon Blow is spot on. The overall quality of software is constantly in decline. I mean … I have 12 CPU cores with around 4 GHz and 64 GB of RAM … and a USB thumb drive copy operation can totally bring down the system.

Sadly there is nothing Asobo can do about any of that. It is a W10 OS issue.

Ok interesting. I plugged in a USB keyboard and took out my Logitech Wireless keyboard and it seems to have helped the situation. I still get a black screen for a long time when I start the program, and then another long pause at the initial loading screen after the logos (during this time getting the not responding message in Task Manager) but then once in the flight it seems much better.

1 Like

I think those pauses are normal, although at first quite confusing.


As mentioned, those are normal.

1 Like

Yes they can. The game is littered with blocking kernel calls.

Name any piece of software that freezes for 15+ seconds if you unplug/plug in an unused USB device.

I never tried to profile the game code … but you might be right. If they use blocking calls then theycould have a way to resolve that.

I have not yet seen the freeze which you mention. Is that related to USB flight controllers or any USB device? For the USB drives which I am using (and disconnecting) I did not see that one.

And as I wrote in my post I have not seen this happening prior to … and I simply suspected that they did not rewrite their USB game controller code during those last upgrade. But I clearly could be wrong on that too.

Seems to be related to battery powered devices and if the freeze occurs
when device is being put to sleep (and wake up) to conserve battery drainage.

If so, the problem occurs with non wired devices:

Wireless USB devices
Bluetooth devices

I have a wired USB mouse and wired USB keyboard
that do not cause freezes.

I have a BT mouse that does not cause these freezes. It has a
battery in it for power.

I have a BT keyboard that causes these freezes.
It has a rechargeable battery.

It may also depend if the device has the ability (designed to be able) to
go to sleep or not (programmed in the driver).

It seems to block while a USB re-enumeration takes places which get triggered by a USB connection.

You can easily play with this in USB Deview and performing a disconnect/reconnect action on a flash disk.

Also, after the freeze recovers your inputs in your USB joystick will be reset, very notable with throttle.

This has been in the game from the start. Many many threads about it.

Anyways, the USB issue is not what this thread is about.

Fun fact: Apparently MS Teams will freeze as well doing this (got this info from a friend, I dont use Teams)


Having what seems like the same issue. Cannot even use the sim.

I just did retry the USB-plug-unplug … and now that I payed attention I could clearly see what @DronkeyKlong described … the game did freeze when the USB stick was inserted.

I’ve been observing (and trying to troubleshoot) what I would described as “intermittent but severe” stuttering.

It doesn’t happen all the time, but it’s regular enough and when it does occur it seems consistent.

Once it starts the “stutters” seem to be paced at reasonably regular intervals and of reasonably regular length.

Running HWInfo visible on a second monitor I can observe that the GPU and all cores drop activity seemingly at the point where the stutters occur. The graph for each thread/GPU will literally show a drop to zero and then pick up again.

While this is happening all temperatures and voltages are well within the range I expect them to be. None of my CPU cores exceeds 40c (overkill water-cooling) and my GPU/GPU memory are also within the manufacturer tolerance & although this is at present air cooled while I wait on a new waterblock for the GPU.

I have checked SSD activity at the same time & I actually can’t see activity on either of my 2 pcie nvme drives that would explain these stutters.

I grabbed some screenies of the HWInfo output that I’ll maybe post later to illustrate the issue.

Stuttering is not freezes. Search for stuttering.

Depends how long the stutters are I suppose. I’ve not been able to accurately time them or the interval but I would say that the pause part of the stutter can last about 3 seconds. (& I have had episodes that feel much longer) and many would describe these as freezes.