MSFS not responding/freezing on loading and World Map Scene – Microsoft Store version

My game freezes on two different situations #pc Microsoft Store version.

I don’t use Developer Mode or made changes in it.

The Freezeng and crash happens when zooming close to the ground on World Map Screen and/or
when loading flight (freezes on 75 %).

I have reinstalled the game – didn’t help. I cleared the Community folder – didn’t help.

I have the latest Win 10 drivers, and Nvidia drivers.

Every other game works perfectly – even from Xbox App.

Does anyone have a proper solution for this? I think I have tried every forum tricks and help document tricks already.

Here’s a video, how it freezes in those two scenarios: Microsoft Flight Simulator not responding and freezing on loading and World Map Scene - YouTube

I started to have this issue after October 2021 update and it has not fixed after the big November update. I don’t want to reinstall Windows. It cannot be the only solution here.

Same exact issue here. Started with poor performance after su7, now after the hotfix I’m unable to even load a flight at all. Says I have a bandwidth issue upon loading the main menu and I’ve been turned to offline mode. Same results regardless of whether I change back to online or not. Community folder is empty, sim freshly reinstalled, hosts file fixed after google mod. No luck. Sim is a brick for me.

64g Ram
1tb NVME


I have the same bandwidth issue too.


If you use or have ever used the Google Maps Replacement add-on/hack, make sure it didn’t leave anything in your hosts file (windows\system32\drivers\etc) Remove or comment out any lines that seem like they might refer to scenery or maps. This fixed the EXACT same issues as illustrated in your video for me.


YES! This was the solution!
I tried the Google Maps mod, and it didn’t work as I dreamed, so I uninstalled. I missed the read me -file’s sentence:

To restore the previous state, please delete
The following two lines in the C:\Windows\System32\drivers\etc\hosts file:

That was the reason. I deleted those two lines from my System32 and the Flight Sim works once again like a charm!

Thank you Goodman98155!