MSFS not showing up in Nvidia Experiance games library

Hello All,

As the title says its not appearing in my games library. I have tried scanning all my drives from the root folder (C: D: E:) and still MSFS doesnt show up. I purchased MSFS thru the Microsoft store. Any ideas? Thanks.

I purchased through MS store and it does show up in my GeForce Experience library however you’re more than likely going to be better off not having NVIDIA monkey around with the program’s settings.
The GeForce Experience will dumb down the graphics to where it can achieve 60 FPS, which in turn will make the sim look like hot garbage. IMO, you’re better off without GFE

If you’re bent on making GFE seeing the sim, make sure you’re on the latest version of GFE. Maybe uninstall, reinstall GFE, and then re-scan for games.

Thanks for input. Yeah I was just looking to use it for NVIDIA’s in game filter. Someone had posted a workaround for the pixelated clouds using it. I might just try reshade or something.

I’m not aware of how that fix is implemented, but you can manipulate the sim’s settings through the NVIDA control panel, without the interference of GFE.

Yeah im able to get it to add there but for some reason not on GFE. This was the post I was referencing that apparently helps with the pixels. I was looking at it further and it might have to do with me “not having permission” to access the flightsimulator.exe file. Cheers.

Interesting. I’ve never used the overlay feature before today. I’ve found the game must first be running to access the overlay. Once the game is up and running, hit ALT F3 to access the overlay in game. And this is with GFE being disabled for MSFS. So give that a shot and see what happens. You may not even need MSFS to be detected for this to work.

For me, I didn’t see much of a difference with the clouds. I’m only running the sim at 1080p on high settings. So that might be why.

It’s a bit of a fudge and needs playing around with to suit the user taste. It helps. I am using the overlay to blur the clouds and to alter the brightness and contrast to try and hide the worst of the problem. The settings I provided will not be to everyone’s taste. Charles

1 Like

Cheers man, your idea worked by just going into MSFS with the overlay! Thanks a lot for the suggestion. The adjustments may not end up working but glad I can at least try now. Thanks again :sunglasses:

1 Like