MSFS (PC) does not start - loop in Press a key

Hi, in the morning all was fine. Now if i start at first: Press key to continue!


After that: Welcome back (UserId) and then ‘Press a key…’
!

Checkes UserId in XBOX App - all fine. Installes nothing new. Please help! Thx Peter

Copy and paste the below to create a batch file in Notepad, i.e. FixLogin.bat:

@echo off
net stop GamingServices >nul 2>&1
net stop GamingServicesNet >nul 2>&1
net start GamingServices >nul 2>&1
net start GamingServicesNet >nul 2>&1
taskkill /f /im gamingservices.exe >nul 2>&1
taskkill /f /im gamingservicesnet.exe >nul 2>&1

Run the batch file and when it’s done, open the Xbox app to verify your login name is showing properly in the left-top corner and you should be good to go.

3 Likes

Today it works again. Dont know why. But… THX for this batch, will keep it for the next Time. :slight_smile:

1 Like

OK so I did it and it worked but it does not answer the lingering questions:

  1. Why the heck is this batch thingy necessary?? Who is Flieger Laie and how did he discover this batch thingy fix?
  2. Is this batch thingy a temporary fix for a development team error? I hope so because I have to do this batch thingy each time I want to fly and that’s disgusting.
  3. I use to start the sim in a special batch file that bypassed all those long drawn out splash screens and started other utilities as well. Now I can’t. I have to suffer through all those unnecessary cinematic credits. Can the devs give us a short version of the startup without all the cinematic crap?
  4. Before this batch thingy, I never had to fool around with the XBOX app. I could just go fly. NOW …in order to fly I have to fool around with the batch thingy first and then the XBOX app!!! I really hate it. I feel like I’m being forced to look at all those other game offerings that I have absolutely no interest in. I’m a serious simmer and not a video gamer.

Devs need to undo this crazy mess that was never done right in the first place because we now have this batch thingy (I stumbled upon because there was no official announcement) we must run each time we start our pc to fly! This can’t be the new norm going forward. If not fixed, I hate it so much I will uninstall and go to P3D or xplane.

I’ve not had problems in the past but your solution worked great for me when I encountered this issue today!

Hi Ibo, to clarify. I was not the developer of the batch. I had the Startup Problem, which was solved by himself. Peter

Well maybe that’s what messed up your sim…
I imagine…
Just like I imagine that cinematic wait that you call (■■■■).
I also imagine that it will be to make the burden of everything more enjoyable for all of us…
I am very imaginative