MSFS problem after system restore with Acronis True Image

After system restore (drive C), MSFS can no longer be started. All “exe” files are specified in the corresponding folders with a size of 0 KB. Does anyone know a solution to this problem?

Your topic has been moved to a sub-category of the User Support Hub

The General Discussion category is meant for discussions that fall outside of our other sub-categories.

If you would like other users to help you with an issue you are experiencing in the sim, consider these User Support Hub categories for your future post:

Aircraft & Systems
ATC, Traffic & NAVAIDs
Crashes (CTDs)
Hardware & Peripherals
Install, Performance & Graphics
Scenery & Airports
User Interface & Activities
Virtual Reality (VR)
Weather & Live Weather

In which sub-category can I founnd it?


I wrote above:

So your topic is now in the correct category, you don’t need to move it again.

Thanks, found it.
I back up the system partition every week to be prepared for unexpected problems. I installed MSFS on a separate SSD, but the installation writes relevant parts of the simulator to the system partition. Wouldn’t be a big deal, but Microsoft/Asobo encrypt some of these files and therefore these files are not backed up properly and are written as zero kilobyte files when restored.
Is there a tutorial somewhere on how I can get the simulator running again without having to do a complete reinstallation?

or – it could be that YOU do not have the correct permissions to read flightsimulator.exe, so it displays as zero bytes.

I see the same, zero bytes, but my MSFS can run, I assume because whatever is starting MSFS, has the correct permissions to run flightsimulator.exe.

(MS /Asobo do NOT want to make it easy for anyone to easuly just go and open Flightsimulator.exe and try messing or debugging it !!) Makes sense to me

Note: I was in Beta (if that is relevant)
Not sure why I seem to have a copy of flightsimulator.exe that I can seem to READ the file size of .

( I may have “changed” MY admin permissions some time ago !!! )

BTW. about a Month ago, I backed up my C drive, replaced it with an bigger one, and restored by C drive image (with Acronis True Image), everything worked as expected … NO Issues

I have also. No problems.

1 Like

Thanks for the infos.
When I start the simulator in the usual way the following window appears.

Translation of the window:

This app cannot be opened

Microsoft Flight Simulator was not found and cannot be opened. The
storage device may be missing or disconnected.
View in store

                                      Copy to clipboard   Close

If I try to start the simulator directly from the simulator directory by double-clicking FlightSimulator.exe, the following window appears:

Just make a back up copy of your data, then uninstall and reinstall to clear any errors. I reinstalled last night after a drive format. It took about 15 minutes. This is with 350GB of data backed up.

1 Like

While that should work, more of a concern is why the Acronis backup/Restore failed for this user, when it has worked fine for others.

The later verson of Acronis “True Disk Image” (or whatever they call it now, is riddled with Bloatware, and is on a subcription model.

The older (discontinued) version, had no Bloatware, was a one time purchase, and work flawlessly.

I purchased an additional License for another 5 PC recently, new version, but was able to PAY an extra “Support Fee”, to have that license downgraded to an older version, without Bloatware, and with a lifetime Pay once license.
It was a painful process to get this, but well worth it in the long run.

Acronis True Image 2018

Sometimes , if it ain’t Broke, don’t FIX it and make it more complicated than it needs to be !!

I don’t know now, if one can still Purchase True Image 2018 from Acronis. – but there do seem to be copies being sold on Ebay !!

I use True Image 2020 and 2022. Both versions with lifetime licenses. All I need is a reliable backup program and not any unwanted additional functions.
The system restore worked, except for MSFS. The system no longer recognizes the simulator installation. I hope I find a solution to this crap somewhere.

My system restore needed more than 3 hours for the 480 gigabytes. All prorams work fine after the revovery, except MSFS, the hell knows for what reason.

Because you did not back up your data folder. The installation software is only 1GB approx.

Did you back up the additional partitions that windows creates for back up data?

Yes I did, I made a Backup Disk Image of the whole Drive, not just a single partition.

1 Like

Something got corrupted then. This may not be the hard drive itself. I would do some stability checks to see that memory and CPU are not throwing out errors. If this is clean check the drives for errors.

MSFS problem after system restore with Acronis True Image (solved)

Reinstalling MSFS solved the problem. The actual reinstallation only took a few seconds, but finding my simulator in the Microsoft Store wasn’t very customer-friendly, in contrast to the possible purchase options for the simulator.

My installation is on its own SSD, not the system SSD (C). (Boxed/DVD Version)
I’ll describe my procedure for the new installation here:

  1. Back up the existing community folder of your installation to a different drive in case something goes wrong. The flight plans you created yourself must also be copied to another location because they will be lost during the reinstallation. Here is the path to find the flight plans: C:\Users\YOUR NAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState.
    It also makes sense to take screenshots of your Sim settings, because they will be reset during installation.
  2. Press the start button on your desktop (Windows logo), then right-click on “Microsoft Flightsimulator” and select uninstall.
  3. Start Microsoft Store
  4. Click on your user icon and check whether the drive and folder for the installation correspond to the old installation, change if necessary. Then click on the user icon again and select Manage account and devices.
  5. Click on the Payment and Billing tab and select the order process
  6. “Select all available” period
  7. Click on your MSFS and select “Install”

After a few seconds the reinstallation is completed. Now copy the flight plans and possibly the community folder back and your Sim will run again. However, the individual settings in the Sim still need to be made because these have been reset to standard settings.
I hope the description for the reinstallation will be usefull to one or more users in successfully completing their reinstallation.

1 Like