MSFS seems to think it’s a 1st time run and going through settings again

As the title suggests, had a power failure while sim was running and upon restarting, MSFS seems to think it’s a 1st time run as it’s going through the suggested settings for graphics and peripheral setup.

Is there any way to retrieve my profile???

This actually doesn’t make any sense (no offense). If such a corruption on the local machine is even possible, what is the point of the cloud sync? Sorry I don’t have a solution but I would avoid running the sim anymore until someone does.

Unfortunately, probably not.
When this occurs, it seems to affect display settings more than all else, so things like logbook etc may still be OK.

I have had this happen twice in the last while.

On Steam there appears to be a local copy of userdata and a cloud copy. Does the MS-Store version have that? Something about the way the entire cloud sync system works seems flawed to me.

Yes, it does, but it does not have the ability to “uncheck” the cloud save as you can with steam.

The sim should implement a basic CRC check to make sure the profile being uploaded to the cloud isn’t corrupt.

What happens if you delete the local userdata with the MS-Store version, will it retrieve and restore the data from the cloud? Perhaps you never tried such a thing. I haven’t.

Yes, I actually have tried.
Every time it has worked as expected.
The only bug has been when the cloud save malfunctions as mentioned above.
For some reason it won’t load the cloud or the local files.
The only thing I can think of may be that the last “save” was corrupt to both the local and the cloud.

1 Like

Happened to me recently too. Thought all my controller profiles had been lost as well. Turned out they were still there, but the selected ones had been set to default.

Not sure whether it happened at the same time, but all my training and bush trip progress was lost.

1 Like

Happened to me.

PC, MS Store.
FS2020 installed on D: drive. Nothing else.
Left SU9 Beta early and ran into problems.

FS2020 loads with XBox display.
Lost Sidewinder 2 FFB joy stick profiles.

Full reinstall twice with no change.
Tried to delete folders on D: but Win 11 would not allow it.

Finally out of frustration:
Used Win 11 Disk Management and “Formatted” the D: drive.

Full install again and everything is back to normal.