MSFS won't load with XPForce running

Hi all,

Issue is that when I start XPForce and it lauches itself and MSFS, MSFS will hang on the first black screen with the rotating circular loading indicator, only the loading indicator doesn’t move and MSFS never loads.
However if I close XPForce MSFS will immediately continue loading as normal.
I’ve tried running both MSFS and XPForce as administrator and that didn’t help.
Anyone got any ideas how to fix this? TIA

Try removing and reinstalling XPForce.

I have version 1.1.0048, and the autostart is working fine, in FS2020 (Steam).

You may have something in your Community folder causing a conflict.

Thanks for the response.
Tried reinstalling XPForce and I’m still getting the same issue.
Only thing that was in my community folder was a custom checklist for the Carenado M20R but I tried removing it anyway and that hasn’t helped.
I even tried turning off autostart of MSFS when XPForce is opened and opening MSFS separately afterwards.
Like you I have XPForce 1.1.0048 and MSFS on Steam so I don’t see what the problem could be.

These are pretty far out there but…
It could be your simconnect . Reinstall the sdk
If you are running ethernet disconnect and try a wifi connection.

I’m on a desktop with no wifi card so not much I can do there, I did try tethering my phones connection over USB but that made no difference.
I also tried uninstalling and reinstalling the SDK (0.18.0.0) but again, no difference.

Is it possible and could it help trying an older version of the SDK? Or would MSFS automatically update it again?

Didn’t XPforce come with its own simconnect?
It has been 2 years since I loaded the simconnect software.
But I do run a diy ffb yoke based on MS FFb2 circuit board.
I also have a motion simulator chair which used its own modded simconnect. Maybe 6 months ago something changed. My yoke had better centering and the chair mellowed out a bit. So something happened on this end…
maybe look for any/all/ other instances of simconnect on your pc and delete them.

One other thing is too look at the task manager and see if
XPforce is still running… If it is running and you click on XPforce again (to load fs2020) it will not load fs2020

1 Like

Still not working for me.
I’ve tried searching for any simconnect files and folders and deleting them (except those in C:/ Windows/ , that I don’t have permission to delete, even as admin).
I’ve tried countless uninstalls and reinstalls of both XPForce and the SDK.
I’ve tried uninstalling MSFS and reinstalling it on a different drive.
I’ve made sure Win 10 is all up to date.

Annoyingly I’ve installed MSFS and XPForce on my laptop and it works perfectly there.

If it at all helps, this is the screen MSFS hangs on until I close XPForce, this is before the Xbox Game Studios or Asobo title screens.

And these are the search results for ‘simconnect’ across all my drives incase anyone can spot something.

I am going to assume your desktop computer has been in use for a while and you have a bunch of stuff loaded on it??
At this point I would get a spare hard drive and install a clean windows 10 operating system and then the sim and xp force.
I assume you have a conflict that is not easily going to be resolved. I did this exact thing 6 months ago. You should be able to transfer most stuff back to the new hard drive.
Not an easy fix but I have no other ideas to continue trouble shooting the problem.
P.S.> did you ever run the google map replacement program?

I have noticed going into the Task Manager then exiting seems to fix hangup problems.
Dave J

Same thing happens to me. Did you try my post below re loading the Task manager then closing it. This gets my MSFS loading with xpforce.
Dave J