MSFS2020 acting as bandwidth limiter

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Before opening MSFS2020 my bandwidth is about 150Mbps (Wifi and by cable). After opening the game, as soon as the menu appears, it starts acting like a limiter. My bandwidth drops under 10Mbps. I’ve also emptied the community folder. I don’t know what to do. I’ve done multiple speed test by different providers.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

start up the game and check the bandwidth

PC specs and/or peripheral set up if relevant:

Lenovo Legion 5 15IMH05H
NVIDIA GeForce RTX 2060
Intel i7-10750H
Wifi adapter: Intel 6 AX201
Ethernet: Realtek PCIe GbE Family Controller

Build Version # when you first started experiencing this issue:

I think it started already before SU9.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Do you have the same issue if you follow the OP’s steps to reproduce it?

No, I cannot reproduce this with my data bandwidth settings set to unlimited.

Provide extra information to complete the original description of the issue:

Steam version, Windows 10 build 19044.1706

Do you have any QoS services running on your PC or in your router itself? I don’t believe this would be MSFS doing this but rather your network reacting to the data consumption / throughput of MSFS.

1 Like

I agree. Applications that don’t have admin or kernel-level privileges probably cannot directly limit the bandwidth of other applications running on the same Windows system.

Not that I’m aware of. I haven’t changed a thing on my laptop. I’ve only installed a VPN client for my work, but that is inactive when I’m starting MSFS2020.

How do you check the bandwidth?

Sounds similar to this:

1 Like

Start that VPN connection, and then start MSFS and see what happens. If it runs just fine then more then likely your provider is limiting your speed.

I did the Google speedtest, the one from speedtest.net and also the one from my internet provider Ziggo. The Google speedtest gave some strange figures, so I don’t think that one is very reliable.

Aside of testing the bandwidth on my laptop, I also did the tests on my mobile phone at the same time. The bandwidth on my mobile phone didn’t change.

I’m still using Windows 10… So I don’t think that’s the issue, but thanks

1 Like

Well I believe that the VPN is only used to connect with my workstation at work. And that all other internet services runs through the normal route. But I’m not that familiar with VPN and internet connections and how all those things work. So I could be wrong.

That makes sense, but it is possible that some VPN configurations can route nearly all network traffic through the VPN tunnel.

This is a possibility. You can find free trial vpn’s on the net and try one of those. Just be careful though if you dont know what your doing you could hose your work vpn. If you have an ‘in house’ computer person at work, ask them if its safe to use another vpn for what your trying to achieve, or ask them if the current one will work.

Are you sure its a vpn connection and not a vnc connection to your work computer?

Sorry, I haven’t got time past couple of days. I just did another test with my mobile phone as a hotspot for my laptop. This was with a 4G connection, so that I could exclude my internet provider at home. And the same thing happened. As soon the simulator home screen opened, it acted like a limiter. The bandwidth dropped again. The speedtests all shows the same image as with the regular internet connection. The bandwidth peaks at the first second and after that it drops immediately.
Patch: 1.26.5.0
No files in the community folder
No bandwidth limit set in the settings




This is not the first time I’ve seen complaints that the game is somehow limiting total bandwidth far below their normal bandwidth. I’ve tested this myself a few times and haven’t been affected. However the game download is never anywhere near my total download speed. It usually tops out around 150-200mbit on my 1gbit connection, but I’ve been able to do speed tests and get a result that is about my total download speed minus what the game update is using.

There must be some configuration difference or driver/hardware issue that is triggering this bandwidth limitation by the game download.

I certainly feel the download process could be better streamlined. It downloads a lot of small files and is opening new connections for each one instead of using the HTTP/2 feature of keeping a connection alive and requesting multiple files which would keep the download speed high instead of having to start slow and ramp up the speed for each file. I’ve also noticed the game opens a lot of connections at the same time, and some drivers/hardware don’t deal well with many simultaneous connections.

Get a copy of ping plotter, now start msfs and get a flight running, now go into task manager, click on the performance tab, then at the bottom click on resources. Now find MSFS in the list of running process, click on it, this will show just msfs related processes. Click on the net interface either eth or wlan, now you see where msfs connections are. Write down the ip’s in the list.

Now you can close MSFS and taskman now, open up pingplotter, and enter one of the pings on the list that you got from when MSFS was running. You should now see how traffic is running along that route, things you should be looking for is either packet loss and or latency. If there are systems along that route that return no info thats to be expected and nothing to worry about. Now if your seeing Packet Loss or latency along the route make note of them.

Now all you have to do is figure out whether those sites are related to your providers network, or if the connection is being stepped on by something on the outside your providers network. If its inside the your providers network, take screen shots (repeated times of day are best) and then provide them with this information. Its was a real PIA to get my provider to admit the problem was them, but eventually they did, of course going on a year they still havent fixed it (high latency issue), but now it seems everytime I fuss I get another 120mbps added to my account, still doesnt fix the latency issue, but Im upto 330mpbs for the price of 100mbps… ;p

a note: MSFS is realy nothing for what your Mobile-Provider offer the “mobile connection”… this kind of connection works in a completly different way than wired ( how the packages priorized, etc. ).

And here my test:
Without MSFS running:
Snap 2022-06-25 at 14.31.10

MSFS in Main-Menu:
image
reval on different test side:
image

=> Result:

  • There is absolutely no Limitation caused from MSFS

I use a Wired Ethernet Connection and there is a long way: switch → swtich → powerline → powerline → router.

So,… may be you have to seach the issue on your System, Network,…

Here are results with my mobile phone as hotspot, using 4G connection, so not my home network.

Without running msfs2020:

Msfs2020 running:

The same thing happens as when I’m using the wired connection from my home network. So it’s not caused by my home network, but something on the laptop.
But I discovered something new, it is also happening when I start Cities Skylines. So I’m not sure what it is. So my laptop is going is some kind of different modus I think, but I don’t know what that could be.

Could it be these updates? Those are the only things that I could think of.

Perhaps you should check whether MSFS or other app is downloading something during your speedtest. It may interfere with the speedtest result.

You can use windows “performance” graph from task manager.

I found the problem. Apparently Lenovo Vantage (some kind of control center which came with the laptop) has a network boost option, which was activated every time I started a game. It was suppose to limit the bandwidth to any other services than the game. But instead of doing that, it also limited the bandwidth of the game. The strange thing is that I never changed a setting of the network boost, maybe something happened after an update. But I feel a bit stupid that I never checked it.
But thanks to everyone who tried to help!

3 Likes